POJ 3259:Wormholes 【SPFA】

Wormholes

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 6   Accepted Submission(s) : 6
Problem Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N,M (1 ≤M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps toF (1 ≤F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

 

Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
 

Output
Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).
 

Sample Input
  
  
2 3 3 1 1 2 2 1 3 4 2 3 1 3 1 3 3 2 1 1 2 3 2 3 4 3 1 8
 

Sample Output
  
  
NO YES
 

首先要理解题意~~John想在穿洞的时候能够回到过去~~~意味着所构建的图中必须有负环;

还有对输入的理解~~每组测试有M个双向正权的~W个单向负权的~~~

AC-code:

#include<cstdio>
#include<cstring>
#include<queue>
#define INF 0x3f3f3f3f
using namespace std;
int num,dis[505],vis[505],used[505],head[505*505];
struct node
{
	int from,to,val,next;
}A[505*505];
void chan(int a,int b,int c)
{
	node e={a,b,c,head[a]};
	A[num]=e;
	head[a]=num++;
}

int spfa(int sx,int n)
{
	memset(vis,0,sizeof(vis));
	memset(dis,INF,sizeof(dis));
	memset(used,0,sizeof(used));
	queue<int>q;
	q.push(sx);
	vis[sx]=1;
	dis[sx]=0;
	used[sx]++;
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		vis[u]=0;
		for(int i=head[u];i!=-1;i=A[i].next)
		{
			int v=A[i].to;
			if(dis[v]>dis[u]+A[i].val)
			{
				dis[v]=dis[u]+A[i].val;
				if(!vis[v])
				{
					vis[v]=1;
					q.push(v);
					used[v]++;
					if(used[v]>n)
						return 1;
				}
			}
		}
	}
	return 0;
}
int main()
{
	int f,m,w,n,s,e,t;
	scanf("%d",&f);
	while(f--)
	{
		num=0;
		memset(head,-1,sizeof(head));
		scanf("%d%d%d",&n,&m,&w);
		while(m--)
		{
			scanf("%d%d%d",&s,&e,&t);
			chan(s,e,t);
			chan(e,s,t);
		}
		while(w--)
		{
			scanf("%d%d%d",&s,&e,&t);
			chan(s,e,-t);
		}
		if(spfa(1,n))
			printf("YES\n");
		else
			printf("NO\n");
	}
	return 0;
}



 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值