HDU 5642:King's Order【DP】

King's Order

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 363    Accepted Submission(s): 219


Problem Description
After the king's speech , everyone is encouraged. But the war is not over. The king needs to give orders from time to time. But sometimes he can not speak things well. So in his order there are some ones like this: "Let the group-p-p three come to me". As you can see letter 'p' repeats for 3 times. Poor king!

Now , it is war time , because of the spies from enemies , sometimes it is pretty hard for the general to tell which orders come from the king. But fortunately the general know how the king speaks: the king never repeats a letter for more than 3 times continually .And only this kind of order is legal. For example , the order: "Let the group-p-p-p three come to me" can never come from the king. While the order:" Let the group-p three come to me" is a legal statement.

The general wants to know how many legal orders that has the length of n

To make it simple , only lower case English Letters can appear in king's order , and please output the answer modulo  1000000007

We regard two strings are the same if and only if each charactor is the same place of these two strings are the same.
 

Input
The first line contains a number  T(T10) ——The number of the testcases.

For each testcase, the first line and the only line contains a positive number  n(n2000) .
 

Output
For each testcase, print a single number as the answer.
 

Sample Input
  
  
2 2 4
 

Sample Output
  
  
676 456950 hint: All the order that has length 2 are legal. So the answer is 26*26. For the order that has length 4. The illegal order are : "aaaa" , "bbbb"…….."zzzz" 26 orders in total. So the answer for n == 4 is 26^4-26 = 456950
 
题意:给你字符串的长度~让你求出总共有多少种使得最多有三个连续相同的由小写字母组成的字符串。
思路:dp,dp[i][j]代表长度为i,最后的边续相同的数量为j的字符串种数。
AC-code:
#include<cstdio>
#define mod 1000000007
long long  dp[2005][4]; 
void pre()
{
	int i,j;
	dp[1][1]=26;
	for(i=1;i<=2000;i++)
		for(j=1;j<=3;j++)
			if(dp[i][j])
			{
				if(j!=3) 
					dp[i+1][j+1]=(dp[i][j]+dp[i+1][j+1])%mod;
				dp[i+1][1]=(dp[i+1][1]+dp[i][j]*25)%mod;
			}
}
int main()
{
	int T,n,i;
	long long ans;
	scanf("%d",&T);
	pre();
	while(T--)
	{
		scanf("%d",&n);
		ans=0;
		for(i=1;i<=3;i++)
			ans=(ans+dp[n][i])%mod;
		printf("%lld\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值