poj The Perfect Stall(二分图匹配)

The Perfect Stall
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 27949 Accepted: 12335

Description
Farmer John completed his new barn just last week, complete with all the latest milking technology. Unfortunately, due to engineering problems, all the stalls in the new barn are different. For the first week, Farmer John randomly assigned cows to stalls, but it quickly became clear that any given cow was only willing to produce milk in certain stalls. For the last week, Farmer John has been collecting data on which cows are willing to produce milk in which stalls. A stall may be only assigned to one cow, and, of course, a cow may be only assigned to one stall.
Given the preferences of the cows, compute the maximum number of milk-producing assignments of cows to stalls that is possible.

Input
The input includes several cases. For each case, the first line contains two integers, N (0 <= N <= 200) and M (0 <= M <= 200). N is the number of cows that Farmer John has and M is the number of stalls in the new barn. Each of the following N lines corresponds to a single cow. The first integer (Si) on the line is the number of stalls that the cow is willing to produce milk in (0 <= Si <= M). The subsequent Si integers on that line are the stalls in which that cow is willing to produce milk. The stall numbers will be integers in the range (1..M), and no stall will be listed twice for a given cow.

Output
For each case, output a single line with a single integer, the maximum number of milk-producing stall assignments that can be made.

Sample Input

5 5
2 2 5
3 2 3 4
2 1 5
3 1 2 5
1 2

Sample Output

4

Source
USACO 40

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;

typedef long long ll;
const int inf=0x3f3f3f3f;
const int maxn = 205;
int edge[maxn][maxn];//edge[i][j] == 1 代表i,j可以匹配
int vis[maxn];//用来记录该点是否被访问过
int cx[maxn], cy[maxn];//用来记录x集合中匹配的y元素是哪个
int nx, ny;//nx表示x集合的顶点个数, ny表示y集合的顶点个数

int line(int u){
    int v;
    for(v = 0; v < ny; v++){
        if(edge[u][v] && !vis[v]){
            vis[v] = 1;
            if(cy[v] == -1 || line(cy[v])){//如果y集合中的v没有匹配或v已经匹配,但从cy[v]中可以找到一条增广路
                cx[u] = v;//找到增广路,修改匹配
                cy[v] = u;
                return 1;
            }
        }
    }
    return 0;
}

int maxmatch(){
    int sum = 0, i;
    memset(cx, 0xff, sizeof(cx));//初始值为-1表示两个集合中都没有匹配的元素
    memset(cy, 0xff, sizeof(cy));
    for(i = 0; i <= nx; i++){
        if(cx[i] == -1){//还没被匹配就执行内部代码
            memset(vis, 0, sizeof(vis));//重置标记为未访问
            sum += line(i);//以 i 为起点开始查找增广路,返回true ,匹配数+1
        }
    }
    return sum;
}

int main(){
    int y, n;
    while(scanf("%d%d", &nx, &ny) != EOF){
        memset(edge, 0, sizeof(edge));
        for(int i = 0; i < nx; i++){
            scanf("%d", &n);
            for(int j = 0; j < n; j++){
                scanf("%d", &y);
                edge[i][y-1] = 1;
            }
        }
        int sum = maxmatch();
        printf("%d\n", sum);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值