poj 3468 A Simple Problem with Integers (区间更新+区间查询)

You have N integers, A1, A2, … , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, … , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
“C a b c” means adding c to each of Aa, Aa+1, … , Ab. -10000 ≤ c ≤ 10000.
“Q a b” means querying the sum of Aa, Aa+1, … , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint
The sums may exceed the range of 32-bit integers.

题意:

给出了一个序列,你需要处理如下两种询问。

"C a b c"表示给[a, b]区间中的值全部增加c (-10000 ≤ c ≤ 10000)。

"Q a b" 询问[a, b]区间中所有值的和。

板子题,,,无需多言

#include<cstdio>
#include<cmath>
using namespace std;

typedef long long ll;
const int N = 100000+10;
ll s, ans;
struct node
{
    ll l, r, w, vis;
}tree[N<<2];

void build(ll rt, ll l, ll r)
{
    tree[rt].l = l; tree[rt].r = r; tree[rt].vis = 0;
    if(l == r){
        scanf("%lld", &tree[rt].w);
        return;
    }
    ll m = (l+r) >> 1;
    build(rt<<1, l, m);
    build(rt<<1|1, m+1, r);
    tree[rt].w = tree[rt<<1].w + tree[rt<<1|1].w;
}

void down(ll rt)
{
    tree[rt<<1].vis += tree[rt].vis;
    tree[rt<<1|1].vis += tree[rt].vis;
    tree[rt<<1].w += (tree[rt<<1].r - tree[rt<<1].l+1)*tree[rt].vis;
    tree[rt<<1|1].w += (tree[rt<<1|1].r - tree[rt<<1|1].l+1)*tree[rt].vis;
    tree[rt].vis = 0;
}

void change_interval(ll rt, ll l, ll r)
{
    if(tree[rt].l >= l && tree[rt].r <=r){
        tree[rt].w += (tree[rt].r - tree[rt].l +1)*s;
        tree[rt].vis += s;
        return ;
    }
    if(tree[rt].vis) down(rt);
    ll m = (tree[rt].l + tree[rt].r)>>1;
    if(l <= m)  change_interval(rt<<1, l, r);
    if(r > m)   change_interval(rt<<1|1, l, r);
    tree[rt].w = tree[rt<<1].w + tree[rt<<1|1].w;
}

void ask_interval(ll rt, ll l, ll r)
{
    if(tree[rt].l >= l && tree[rt].r <= r){
        ans += tree[rt].w;
        return ;
    }
    if(tree[rt].vis)    down(rt);
    ll m = (tree[rt].l + tree[rt].r)>>1;
    if(l <= m)  ask_interval(rt<<1, l, r);
    if(r > m)   ask_interval(rt<<1|1, l, r);
}

int main()
{
    ll n, q, l, r;
    char c;
    scanf("%lld%lld", &n, &q);
    build(1, 1, n);
    while(q--){
        getchar();
        scanf("%c%lld%lld", &c, &l, &r);
        if(c == 'Q'){
            ans = 0;
            ask_interval(1, l, r);
            printf("%lld\n", ans);
        }
        else if(c == 'C'){
            scanf("%lld", &s);
            change_interval(1, l, r);
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值