Square= =……拼正方形

Time Limit: 5000 ms     Memory Limit: 65536 KB
Total Submit: 18     Accepted: 9 

Description
Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?

Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 
4≤M≤20, the number of sticks. M integers follow; each gives the length of a stick - an integer 
between 1 and 10000. 

Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no". 

Sample Input
3
4 1 1 1 1
5 10 20 30 40 50
8 1 7 2 6 4 4 3 5


Sample Output
yes
no
yes

#include <iostream>
#include <string>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <iostream>
#include <string>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <queue>
using namespace std;
int n;//棍子的个数;
int sum;//总的长度;
int l[25];//放棍子;
int used[25];//是否被使用;
int bian;//每条边的长度;
bool ok;//是否可以组成正方形;
bool cmp(int a,int b){
    return a>b;
}

void DFS(int i,int cnt,int nlen){//i代表从用的第几个棍子,cnt代表已经组成的边的个数,nlen代表当前组成的长度;
    if(cnt==3){
        ok=1;
        return ;
    }
    if(ok==0){
        for(int j=i;j<n;j++){//从j个棍子找起;
            if(!used[j] && nlen+l[j]<=bian){//如果当前棍子未被使用,并且其和小于边长;
                used[j]=1;//标记为使用;
                if(nlen+l[j]==bian)
                    DFS(0,cnt+1,0);//找到一边,重新开始找下一边;
                else
                    DFS(j+1,cnt,nlen+l[j]);//否则找下一个棍子;
                used[j]=0;//传说中的回溯= =……;
            }
        }
    }
}

int main(){
    int t;
    scanf("%d",&t);//t个总数;
    while(t--){
        ok=0;
        sum=0;//总数清空……刚开始没清空…… 过了组BT的…… 屁颠屁颠的去交…… 差点WA一次……
        scanf("%d",&n);
        for(int i=0;i<n;i++){
            scanf("%d",&l[i]);
            sum+=l[i];
        }
        sort(l,l+n,cmp);
        if(sum%4!=0){//如果无法被4整出,则无法构成正方形;
            puts("no");
            continue;
        }
        else{
            bian=sum/4;
            if(l[0]>bian){//如果最长的比边长大,必然无法构成正方形;
                puts("no");
                continue;
            }
            DFS(0,0,0);
            if(ok==1)
                puts("yes");
            else
                puts("no");
        }
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值