线段树——A Simple Problem with Integers

线段树——A Simple Problem with Integers

You have N integers, A1, A2, … , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, … , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
“C a b c” means adding c to each of Aa, Aa+1, … , Ab. -10000 ≤ c ≤ 10000.
“Q a b” means querying the sum of Aa, Aa+1, … , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
const int N=110000;
ll f[N];
struct node{
	ll sum,lazy;
	int l,r;
}a[N*4];
void update(int k)
{
	a[k].sum=a[k*2].sum+a[k*2+1].sum;
}
void build(int k,int l,int r)
{
	a[k].l=l;
	a[k].r=r;
	a[k].lazy=0;
	if(l==r){
		a[k].sum=f[l];
		return ;
	}
	int mid=(a[k].l+a[k].r)/2;
	build(k*2,l,mid);
	build(k*2+1,mid+1,r);
	update(k);
}
void pushdown(int k)
{
	if(a[k].l==a[k].r){
		a[k].lazy=0;
		return ;
	}
	a[k*2].sum+=(a[k*2].r-a[k*2].l+1)*a[k].lazy;
	a[k*2+1].sum+=(a[k*2+1].r-a[k*2+1].l+1)*a[k].lazy;
	a[k*2].lazy+=a[k].lazy;
	a[k*2+1].lazy+=a[k].lazy;
	a[k].lazy=0;
}
void changeSegment(int k,int l,int r,int x)
{
	if(a[k].l==l&&a[k].r==r){
		a[k].sum+=(r-l+1)*x;
		a[k].lazy+=x;
		return ;
	}
	if(a[k].l==a[k].r){
		return;
	}
	if(a[k].lazy!=0){
		pushdown(k);
	}
	int mid=(a[k].l+a[k].r)/2;
	if(r<=mid){
		changeSegment(k*2,l,r,x);
	}
	else if(l>mid){
		changeSegment(k*2+1,l,r,x);
	}
	else{
		changeSegment(k*2,l,mid,x);
		changeSegment(k*2+1,mid+1,r,x);
	}
	update(k);
}

ll query(int k,int l,int r)
{
	if(a[k].lazy!=0){
		pushdown(k);
	}
	if(a[k].l==l&&a[k].r==r){
		return a[k].sum;
	}
	int mid=(a[k].l+a[k].r)/2;
	if(r<=mid){
		return query(k*2,l,r);
	}
	else if(l>mid){
		return query(k*2+1,l,r);
	}
	else
		return query(k*2,l,mid)+query(k*2+1,mid+1,r);
}
int main()
{
	int m,n;
	scanf("%d%d",&m,&n);
	for(int i=1;i<=m;i++){
		scanf("%lld",&f[i]);
	}
	build(1,1,m);
	char c;
	int d,e;
	ll g;
	while(n--){
		getchar();
		scanf("%c",&c);
		if(c=='Q'){
			scanf("%d%d",&d,&e);
			ll s=query(1,d,e);
			printf("%lld\n",s);
		}
		else if(c=='C'){
			scanf("%d%d%lld",&d,&e,&g);
			changeSegment(1,d,e,g);
		}
	}
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值