数据结构实验之链表五:单链表的拆分

数据结构实验之链表五:单链表的拆分

 

Problem Description

输入N个整数顺序建立一个单链表,将该单链表拆分成两个子链表,第一个子链表存放了所有的偶数,第二个子链表存放了所有的奇数。两个子链表中数据的相对次序与原链表一致。

Input

第一行输入整数N;;
第二行依次输入N个整数。

Output

第一行分别输出偶数链表与奇数链表的元素个数;
第二行依次输出偶数子链表的所有数据;
第三行依次输出奇数子链表的所有数据。

Sample Input

10
1 3 22 8 15 999 9 44 6 1001

Sample Output

4 6
22 8 44 6 
1 3 15 999 9 1001

Hint

不得使用数组!

Source

#include <stdio.h>
#include <stdlib.h>


struct node *head1 , *head2 , *head;

struct node
{
    int data;
    struct node *next;
};

void creat_list(int n)
{
    struct node *p , *q ;
    head = (struct node *)malloc(sizeof (struct node ));
    p = head;
    p ->next = NULL;
    while(n--)
    {
        q = (struct node *)malloc(sizeof (struct node ));
        scanf("%d" , &q->data);
        p ->next = q;
        p = q;
        p ->next = NULL;
    }
}

void  chailist()
{
    struct node *pa , *pb;
    struct node *p;
    int i , j;
    i = j = 0;
    p = head ->next;
    head1= (struct node *)malloc(sizeof (struct node ));
    head2= (struct node *)malloc(sizeof (struct node ));
    pa = head1;
    pb = head2;
    while(p)
    {
        if (p ->data % 2 == 0)
        {
            i++;
            pb ->next = p;
           pb = p;
           p = p->next;
           pb ->next = NULL;
        }
        else
        {
            j++;
            pa ->next = p;
            pa= p;
           p = p->next;
           pa ->next = NULL;
        }

    }
    printf("%d %d\n" , i , j);
}

 

void prin_list(struct node *head)
{
    struct node *p;
    p = head->next;
    while(p)
    {
        if (p ->next == NULL)
        {
            printf("%d\n" , p->data);
        }
        else
        {
            printf("%d " , p ->data);
        }
        p = p->next;
    }
}

int main()
{
    int n;
    scanf("%d" , &n);
    creat_list(n);

    chailist();
    prin_list(head2);
    prin_list(head1);
    return 0;
}
 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值