AYITACM2016省赛第一周(深搜) E - A Knight's Journey骑士的旅行



Description

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

分析:

找到骑士旅行的规律,当他旅行过所有的国家,就说明可以,注意回溯!


#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
struct data
{
    int x,y;
} a[33];
int m,n,flag,s[110][110],v[8][2]={-2,-1,-2,1,-1,-2,-1,2,1,-2,1,2,2,-1,2,1};
void  dfs(int x,int y,int z)
{
    a[z].x=x;  //把走过的国家赋值到结构体中
    a[z].y=y;
    if(z==m*n) 
    {
        flag=1; //如果走完所有的国家,标记然后返回
        return ;
    }
    for(int i=0; i<8; i++)
    {
        int x1=x+v[i][0];
        int y1=y+v[i][1];
        if(x1>0&&x1<=m&&y1>0&&y1<=n&&!s[x1][y1]&&!flag)
        {   //如果没有越界且这个国家还没有走,也没有走完
            s[x1][y1]=1;
            dfs(x1,y1,z+1);//走过的国家加一
            s[x1][y1]=0;// 回溯
        }
    }
}
int main()
{
    int t,k=1;;
    scanf("%d",&t);
    while(t--)
    {
        memset(s,0,sizeof(s));
        scanf("%d %d",&n,&m);
        flag=0;
        s[1][1]=1;
        dfs(1,1,1);
        printf("Scenario #%d:\n",k++);
        if(flag)
        {
            for(int i=1; i<=m*n; i++)
                printf("%c%d",a[i].x-1+'A',a[i].y);
            printf("\n");
        }
        else
            printf("impossible\n");
        if(t)
            printf("\n");
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值