AYITACM2016省赛第三周D-max sum(DP最大字段和)

Description

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14. 
 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000). 
 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases. 
 

Sample Input

    
    
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output

    
    
Case 1: 14 1 4 Case 2: 7 1 6
分析:

题意很简单,就是求最大的字段和,但是如果按照思路写出来的程序一定会时间超限,所以要想办法优化代码,简化时间,有两种办法,但思路都是差不多的!

第一种:

#include<stdio.h>
#include<string.h>
int main()
{

    int t,n,a,i,j,s,x,y,m,c=1;
    scanf("%d",&t);
    while(t--)
    {
        if(c!=1)
            printf("\n");
        scanf("%d%d",&n,&a);
        s=m=a;  //最大值和初始值都赋值为第一个数
        x=y=j=1;//坐标都初始为1
        for(i=2; i<=n; i++)
        {
            scanf("%d",&a);
            if(s+a<a) //如果加上a还不如不加,那就从此位置重新开始
            {
                s=a;
                j=i;    //重新定初值和起始位置
            }
            else
                s+=a;   //如果不是的话,继续向前加
            if(s>m)   //随时更新最优解
            {
                m=s;
                x=j;
                y=i;
            }
        }
        printf("Case %d:\n%d %d %d\n",c++,m,x,y);
    }
    return 0;
}
第二种:

#include<stdio.h>
#include<string.h>
int main()
{

    int t,n,a,i,j,s,x,y,m,c=1;
    scanf("%d",&t);
    while(t--)
    {
        if(c!=1)
            printf("\n");
        scanf("%d",&n);
        s=0;
        m=-1010;
        j=1;//坐标都初始为1
        for(i=1; i<=n; i++)
        {
            scanf("%d",&a);
                s+=a;   //如果不是的话,继续向前加
            if(s>m)   //随时更新最优解
            {
                m=s;
                x=j;
                y=i;
            }
            if(s<0)
            {
               s=0;
               j=i+1;
            }
        }
        printf("Case %d:\n%d %d %d\n",c++,m,x,y);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值