解题报告 之 UVA116 Unidirectional TSP

解题报告 之 UVA116 Unidirectional TSP


Description

Download as PDF

Background

Problems that require minimum paths through some domain appear in many different areas of computer science. For example, one of the constraints in VLSI routing problems is minimizing wire length. The Traveling Salesperson Problem (TSP) -- finding whether all the cities in a salesperson's route can be visited exactly once with a specified limit on travel time -- is one of the canonical examples of an NP-complete problem; solutions appear to require an inordinate amount of time to generate, but are simple to check.

This problem deals with finding a minimal path through a grid of points while traveling only from left to right.

The Problem

Given an tex2html_wrap_inline352 matrix of integers, you are to write a program that computes a path of minimal weight. A path starts anywhere in column 1 (the first column) and consists of a sequence of steps terminating in column n (the last column). A step consists of traveling from column i to column i+1 in an adjacent (horizontal or diagonal) row. The first and last rows (rows 1 and m) of a matrix are considered adjacent, i.e., the matrix ``wraps'' so that it represents a horizontal cylinder. Legal steps are illustrated below.

picture25

The weight of a path is the sum of the integers in each of the n cells of the matrix that are visited.

For example, two slightly different tex2html_wrap_inline366 matrices are shown below (the only difference is the numbers in the bottom row).

picture37

The minimal path is illustrated for each matrix. Note that the path for the matrix on the right takes advantage of the adjacency property of the first and last rows.

The Input

The input consists of a sequence of matrix specifications. Each matrix specification consists of the row and column dimensions in that order on a line followed by tex2html_wrap_inline376 integers where m is the row dimension and n is the column dimension. The integers appear in the input in row major order, i.e., the first nintegers constitute the first row of the matrix, the second n integers constitute the second row and so on. The integers on a line will be separated from other integers by one or more spaces. Note: integers are not restricted to being positive. There will be one or more matrix specifications in an input file. Input is terminated by end-of-file.

For each specification the number of rows will be between 1 and 10 inclusive; the number of columns will be between 1 and 100 inclusive. No path's weight will exceed integer values representable using 30 bits.

The Output

Two lines should be output for each matrix specification in the input file, the first line represents a minimal-weight path, and the second line is the cost of a minimal path. The path consists of a sequence of n integers (separated by one or more spaces) representing the rows that constitute the minimal path. If there is more than one path of minimal weight the path that is lexicographically smallest should be output.

Sample Input

5 6
3 4 1 2 8 6
6 1 8 2 7 4
5 9 3 9 9 5
8 4 1 3 2 6
3 7 2 8 6 4
5 6
3 4 1 2 8 6
6 1 8 2 7 4
5 9 3 9 9 5
8 4 1 3 2 6
3 7 2 1 2 3
2 2
9 10 9 10

Sample Output

1 2 3 4 4 5
16
1 2 1 5 4 5
11
1 1
19


题目大意:给一个m行n列的整数矩阵,从第一列任意一位置出发,每一步向右走,向右上走,或者向右下走。求走到最右边为止,求路径和最小的一条路径。注意最后一行的上一行是第一行,第一行的下一行是最后一行。


分析:明显是DP,引入阶段的概念,将每一列作为一个阶段,dp[i][j]表示走到i,j时到达最右还需要和的最小值。则边界条件是dp[i][n-1]=num[i][n-1] (行列从0开始),转移方程为dp[i][j]=min(dp[(i-1+m)%m][j+1], dp[i][j+1], dp[(i+1)%m][j+1])+num[i][j]。最后再遍历第一列的所有可能取最小值即可。


至于字典序最小,直接从上到下考虑即可。先将(i-1+m)%m, i, (i+1)%m 排序即可。


下面上代码:

#include <iostream>
#include <algorithm>
#define INF 0x3f3f3f3f
using namespace std;

int m, n;
int num[15][110];
int dp[15][110];
int Next[15][110];
int first=0,ans=INF;

int DP(int i, int j)
{
	if (dp[i][j] < INF) return dp[i][j];
	if (j == n - 1) return dp[i][j] = num[i][j];
	int row[3] = { i, i - 1, i + 1 };
	if (i - 1 < 0) row[1] = m - 1;
	if (i + 1 >= m) row[2] = 0;

	sort(row, row + 3);
	for (int k = 0; k < 3; k++)
	{
		int v = DP(row[k], j + 1) + num[i][j];
		if (v < dp[i][j])
		{
			dp[i][j] = v;
			Next[i][j] = row[k];
		}
	}

	return dp[i][j];
}

int main()
{
	while (cin>>m>>n)
	{
		ans = INF;
		first = 0;
		for (int i = 0; i < m;i++)
		for (int j = 0; j < n; j++)
		{
			cin >> num[i][j];
			dp[i][j] = INF;
		}
		
		for (int i = 0; i < m; i++)
		{
			int tem=DP(i, 0);
			if (tem < ans)
			{
				ans = tem;
				first = i;
			}

		}

		for (int j = 0, i = first; j < n; i = Next[i][j], j++)
		{
			cout << i+1;
			if (j!= n - 1)
				cout << " ";
			else
				cout << endl;
		}
		cout << ans << endl;
		

	}
	return 0;
}


就是这样!




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值