第四十九题 UVA116 单向TSP Unidirectional TSP

116 篇文章 1 订阅
102 篇文章 1 订阅

PDF

Problems that require minimum paths through some domain appear in many different areas of computer
science. For example, one of the constraints in VLSI routing problems is minimizing wire length. The
Traveling Salesperson Problem (TSP) — finding whether all the cities in a salesperson’s route can be
visited exactly once with a specified limit on travel time — is one of the canonical examples of an
NP-complete problem; solutions appear to require an inordinate amount of time to generate, but are
simple to check.
This problem deals with finding a minimal path through a grid of points while traveling only from
left to right.
Given an m×n matrix of integers, you are to write a program that computes a path
of minimal weight. A path starts anywhere in column 1 (the first column) and consists
of a sequence of steps terminating in column n (the last column). A step consists of
traveling from column i to column i + 1 in an adjacent (horizontal or diagonal) row.
The first and last rows (rows 1 and m) of a matrix are considered adjacent, i.e., the
matrix “wraps” so that it represents a horizontal cylinder. Legal steps are illustrated
on the right.
The weight of a path is the sum of the integers in each of the n cells of the matrix that are visited.
For example, two slightly different 5×6 matrices are shown below (the only difference is the numbers
in the bottom row).
The minimal path is illustrated for each matrix. Note that the path for the matrix on the right
takes advantage of the adjacency property of the first and last rows.
Input
The input consists of a sequence of matrix specifications. Each matrix specification consists of the row
and column dimensions in that order on a line followed by m · n integers where m is the row dimension
and n is the column dimension. The integers appear in the input in row major order, i.e., the first n
integers constitute the first row of the matrix, the second n integers constitute the second row and so
on. The integers on a line will be separated from other integers by one or more spaces. Note: integers
are not restricted to being positive.
There will be one or more matrix specifications in an input file. Input is terminated by end-of-file.
For each specification the number of rows will be between 1 and 10 inclusive; the number of columns
will be between 1 and 100 inclusive. No path’s weight will exceed integer values representable using 30
bits.
Output
Two lines should be output for each matrix specification in the input file, the first line represents a
minimal-weight path, and the second line is the cost of a minimal path. The path consists of a sequence
of n integers (separated by one or more spaces) representing the rows that constitute the minimal path.
If there is more than one path of minimal weight the path that is lexicographically smallest should be
output.
Note: Lexicographically means the natural order on sequences induced by the order on their elements.
Sample Input
5 6
3 4 1 2 8 6
6 1 8 2 7 4
5 9 3 9 9 5
8 4 1 3 2 6
3 7 2 8 6 4
5 6
3 4 1 2 8 6
6 1 8 2 7 4
5 9 3 9 9 5
8 4 1 3 2 6
3 7 2 1 2 3
2 2
9 10 9 10
Sample Output
1 2 3 4 4 5
16
1 2 1 5 4 5
11
1 1
19

//f[i][j] 表示(i,j)到最后一列的某点的 路径最小值 这样一来 可以相处倒推 
//还有就是 本题是m行n列  有点别扭不过是小事情了 
#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#define Maxm 11
#define Maxn 102

using namespace std;
int f[Maxm][Maxn],d[Maxm][Maxn],path[Maxm][Maxn];
const int INF = 0x3f3f3f3f;

int main(int argc,char* argv[])  {
	int n,m; 
	while(scanf("%d %d",&m,&n) == 2) {
		memset(f,0x3f,sizeof(f));
		memset(path,0,sizeof(path));
		for(int i=1; i<=m; i++)
			for(int j=1; j<=n; j++) scanf("%d",&d[i][j]);
			
		for(int j=n; j>=1; j--) {// n 列 
			for(int i=1; i<=m; i++) {// m 行 
				if(j == n) f[i][j] = d[i][j];
				else {
					int dx[] = {i+1,i,i-1};// 上下行 
					if(i == 1) dx[2] = m;
					if(i == m) dx[0] = 1;
					sort(dx,dx + 3);
					for(int k=0; k<3; k++)
						if(f[i][j] > f[dx[k]][j + 1] + d[i][j]) {
							f[i][j] = f[dx[k]][j + 1] + d[i][j];
							path[i][j] = dx[k];
						}
				}
			}
		}
		int Ans = INF,Num;
		
		for(int i=1; i<=m; i++)
			if(f[i][1] < Ans) Ans = f[i][1],Num = i;
		printf("%d",Num);
		for(int i=2,j=path[Num][1]; j;j=path[j][i],i++) printf(" %d",j);// 这个地方 输出路径
		// 自己多想一下   我当时就路径都记录对了 输出调试了好几回 
		printf("\n%d\n",Ans);
	}
	
	
	
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

七情六欲·

学生党不容易~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值