HDU 1087

Problem Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.
 

Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N 
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the maximum according to rules, and one line one case.
 

Sample Input
  
  
3 1 3 2 4 1 2 3 4 4 3 3 2 1 0
 

Sample Output
  
  
4 10 3
 

Author
lcy
一道简单的dp,思路如下:
重点是解决子问题:
首先 遍历每一个数, 第一重循环,然后对每一个数,又从头进行遍历,这是第二层循环;如果a[i]>a[j],则构成上升序列,继续遍历;)用一个max数组来储存每一个结果,在max数组里找出最大结果就ok了;
#include<stdio.h>
int main()
{
int n,i,j;                                     
int max1;                                                   //定义最大的一个;
int max[1000];                                            //最大的数值对应的存入
int a[1000];                                                  //存放输入 的数据
while(scanf("%d",&n)!=EOF)                
{
if(n==0)
break;
for(i=1;i<=n;i++) 
{
scanf("%d",&a[i]);
}
max[1]=a[1];                                       //开始:把最大的标记为a[1],因为a[1]是边界,a[1]以前的没法跳;
for(i=2;i<=n;i++)                               //从2开始算;
{
max1=a[i];                                  把最大的标标记为a[i];
for(j=1;j<i;j++)                              //从头开始算;到i的前一步;
{
if(a[i]>a[j]&&a[i]+max[j]>max1) //根据题意;如果a[i]>a[j]进行第二次遍历;
{
max1=a[i]+max[j];
}
max[i]=max1;
}
}
max1=max[1];
for(i=2;i<=n;i++)                                    //找出最大值
{
if(max[i]>max1)
{
max1=max[i];


}
}
printf("%d\n",max1);
}
return 0;
}



这道题可以找一组数据简单模拟一下就懂了。:4 1 2 3 4
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值