HDU 1501 Zipper

Problem Description
Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming "tcraete" from "cat" and "tree":

String A: cat
String B: tree
String C: tcraete


As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree":

String A: cat
String B: tree
String C: catrtee


Finally, notice that it is impossible to form "cttaree" from "cat" and "tree".
 

Input
The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.

 

Output
For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.
 

Sample Input
  
  
3 cat tree tcraete cat tree catrtee cat tree cttaree
 

Sample Output
  
  
Data set 1: yes Data set 2: yes Data set 3: no
 

Source


题意:给定两个字符串,从这两个字符串中取字母,(必须按照从左到右的顺序进行,如果取字符时前面有字符没有取到则不能取此字符,当然两个字符串中的字符可以交叉取。)
#include<stdio.h>
#include<string.h>
char str1[600],str2[600],str3[600];
int dp[201][201];
int a,b,c;                     //ab为俩个字符串的长度,c为总长度
int dfs(int x,int y,int z)
{
	
	if(z>=c)                    //如果超过总长度          
		return -1;

	if(dp[x][y]!=0)                 //如果已经找到,直接返回
		return dp[x][y];
	if(str1[x]!=str3[z]&&str2[y]!=str3[z])//如果str3的字符在1和2 中找不到。
	{
		dp[x][y]=-1;
		return dp[x][y];
	}
	int ans=0;                 结果;
	if(str1[x]==str3[z])       如果1==3
	{
		if(z+1==c)       如果到达顶端
			dp[x][y]=1;     dp=1
		else
			dp[x][y]=dfs(x+1,y,z+1);如果没有。继续dfs

	}
	ans=dp[x][y];
	if(str2[y]==str3[z])               //在y上的处理和在x上的处理一样
	{
		if(z+1==c)
			dp[x][y]=1;
		else 
			dp[x][y]=dfs(x,y+1,z+1);
	}	
	if(ans==1)      //如果可以。
		dp[x][y]=1;
	return dp[x][y];          返回dp=1;
}
int main()
{
	int n;
	int k=1;
	scanf("%d",&n);
	while(n--)
	{
		scanf("%s%s%s",str1,str2,str3);	
		printf("Data set %d: ",k++);
		a=strlen(str1);
		b=strlen(str2);
		c=strlen(str3);
		if(a+b!=c)              //处理一下
		{
		printf("no\n");
			continue;
		}
			int i,j;
			for(i=0;i<=a;i++)
				for(j=0;j<=b;j++)
					dp[i][j]=0;
				int flog=0;
				flog=dfs(0,0,0);
					if(flog==1)
					printf("yes\n");
					else printf("no\n");

	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值