1101 Quick Sort (25分)

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

  • 1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
  • 3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
  • 2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
  • and for the similar reason, 4 and 5 could also be the pivot.

Hence in total there are 3 pivot candidates.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then the next line contains N distinct positive integers no larger than 10​9​​. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

5
1 3 2 4 5

Sample Output:

3
1 4 5

思路:从左到右记录到每个位置为止出现过的最大值maxx[i],从右到左记录到每个位置为止的最小值minn[i],然后扫描一遍数组,当当前元素a[i]大于等于(题目说每个元素是唯一的,所有等于的情况只可能是最大值就是a[i]本身) maxx[i],且小于等于最小值minn[i]。

#include<bits/stdc++.h>
using namespace std;
int a[100010],maxx[100010],minn[100010];
vector<int> ve;
int main(){
    int n;
    scanf("%d", &n);
    for(int i=0;i<n;++i) scanf("%d", &a[i]);
    maxx[0]=a[0];
    for(int i=1;i<n;++i)
        if(a[i]>maxx[i-1]) maxx[i]=a[i];
        else maxx[i]=maxx[i-1];
    minn[n-1]=a[n-1];
    for(int i=n-2;i>=0;--i)
        if(a[i]<minn[i+1]) minn[i]=a[i];
        else minn[i]=minn[i+1];
    for(int i=0;i<n;++i)
        if(a[i]>=maxx[i] && a[i]<=minn[i]) ve.push_back(a[i]);
    int len = ve.size();

    printf("%d\n", len);
    sort(ve.begin(), ve.end());
    for(int i=0;i<len;++i){
        if(i!=0) cout<<" ";
        cout<<ve[i];
    }
    printf("\n");
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值