1112 Stucked Keyboard (20分)

26 篇文章 0 订阅

On a broken keyboard, some of the keys are always stucked. So when you type some sentences, the characters corresponding to those keys will appear repeatedly on screen for k times.

Now given a resulting string on screen, you are supposed to list all the possible stucked keys, and the original string.

Notice that there might be some characters that are typed repeatedly. The stucked key will always repeat output for a fixed k times whenever it is pressed. For example, when k=3, from the string thiiis iiisss a teeeeeest we know that the keys i and e might be stucked, but s is not even though it appears repeatedly sometimes. The original string could be this isss a teest.

Input Specification:

Each input file contains one test case. For each case, the 1st line gives a positive integer k (1<k≤100) which is the output repeating times of a stucked key. The 2nd line contains the resulting string on screen, which consists of no more than 1000 characters from {a-z}, {0-9} and _. It is guaranteed that the string is non-empty.

Output Specification:

For each test case, print in one line the possible stucked keys, in the order of being detected. Make sure that each key is printed once only. Then in the next line print the original string. It is guaranteed that there is at least one stucked key.

Sample Input:

3
caseee1__thiiis_iiisss_a_teeeeeest

Sample Output:

ei
case1__this_isss_a_teest
#include<bits/stdc++.h>
using namespace std;
vector<char> v, ans;
map<char, int> y, no;
int main(){
    int n;
    string s;
    cin>>n>>s;
    int len = s.length();
    v.push_back(s[0]);
    for(int i=1;i<len;++i){
        if(s[i]!=v[0]){
            if(v.size()%n==0 && y[v[0]]==0){
                ans.push_back(v[0]);
                y[v[0]]=1;
            }else if(v.size()%n)
                no[v[0]]=1;
            v.clear();
            v.push_back(s[i]);
        }else v.push_back(s[i]);
    }
    if(!v.empty()){
        if(v.size()%n==0 && y[v[0]]==0){
            ans.push_back(v[0]);
            y[v[0]]=1;
        }else if(v.size()%n)
            no[v[0]]=1;
        v.clear();
    }
    int lena = ans.size();
    for(int i=0; i<lena; ++i)
        if(no.count(ans[i])==0) cout<<ans[i];
    cout<<endl;
    for(int i=0; i<len; ++i)
        if(y.count(s[i]) && !no.count(s[i])){
            int cnt=0;
            char t = s[i];
            while(i<len && t == s[i]){
                cnt++;
                i++;
            }
            for(int j=0; j<cnt/n; ++j) cout<<t;
            i--;
        }else cout<<s[i];
    cout<<endl;
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值