1001 A+B Format (20分)

26 篇文章 0 订阅

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991
#include<bits/stdc++.h>
using namespace std;
int main(){
    int a,b;
//    while(1){
        scanf("%d%d", &a, &b);
        int ans = a + b;
        if(ans < 0){
            printf("-");
            ans = -ans;
        }
        if(ans < 1000){
            printf("%d", ans);
        }else{
            string s;
            stack <string> st;
            while(ans > 0){
                s += '0'+(ans%10);
                ans/=10;
                if(s.length() == 3){
                    st.push(s);
                    s="";
                }
            }
            if(s!="") st.push(s);
            while(!st.empty()){
                string s = st.top();
                st.pop();
                int len = s.length();
                for(int i = len - 1; i >= 0; --i) printf("%c", s[i]);
                if(!st.empty()) printf(",");
            }
        }
//    }
    return 0;
}
#include<bits/stdc++.h>
using namespace  std;

inline int mypow(int a, int b){
    int ans = 1;
    if(b > 0){
        while(b){
            ans *= a;
            -- b;
        }
    }
    else if(b < 0) ans = -1;
    return ans;
}

int main(){
    int a, b, c, cc;
    cin >> a >> b;

    c = a + b;
    if(c < 0) cout<<"-";
    c = abs(c);
    cc = c;

    int len = 0;
    while(cc) cc = cc / 10, ++ len;
    int lef = len % 3;


    if(lef){
        for(int i = 0; i < lef; ++ i){
            cout << c / mypow(10, len - 1) % 10;
            len--;
        }
        if(len != 0) cout<<",";
    }

    while(len){
        for(int i = 0; i < 3; ++ i){
            if(len <= 0) break;
            cout << c / mypow(10, len - 1) % 10;
            len--;
        }
        if(len != 0) cout<<",";
    }

    if(c == 0) cout<<0<<endl;

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值