Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input
Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.
Output
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input-1000000 9Sample Output
-999,991
下面的方法应该是此题的最简单明了的解法:
#include <iostream>
#include <cstdio>
using namespace std;
/*
* 由于a + b的结果在-2000000到2000000之间,范围不大,可以分情况输出
*/
int main(void)
{
int a, b, c;
scanf("%d%d", &a, &b);
c = a + b;
if ( c < 0)
{
printf("-");
c = -c;
}
if (c < 1000)
printf("%d\n", c);
else if (c < 1000000)
printf("%d,%03d\n", c / 1000, c % 1000);
else
printf("%d,%03d,%03d\n", c / 1000000, (c / 1000) % 1000, c % 1000);
return 0;
}