HDU - 1005 Number Sequence 周期是48?不,是336!

题目:

Description

A number sequence is defined as follows: 

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7. 

Given A, B, and n, you are to calculate the value of f(n). 

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed. 

Output

For each test case, print the value of f(n) on a single line. 

Sample Input

1 1 3
1 2 10
0 0 0

Sample Output

2
5


显然,这是一个找周期的问题。

如果oj后台水的话,以7*7 = 49为周期,可能就直接过了。

但看到一位大佬写的,应该是以49*7 = 366为周期

AC代码:

# include <stdio.h>

int main(void)
{
	int a, b, n, t, t1, temp;
	while (~ scanf("%d %d %d", &a, &b, &n))
	{
		if (a == 0 && b == 0 && n == 0)
			break;
			
		if (a % 7 == 0 && b % 7 == 0)  // 如果都是7的倍数,对7取余都为0 所有f(3), f(4)等等都是0 
		{                              // 只有f(1), f(2), 有初值,都为1,输出1即可。 
			if (n < 3)
				printf("1\n");
			else 
				printf("0\n");
				
			continue;
		}
		t = 1, t1 = 1;
		n = (n+333)%336 + 1; // n=3时336%336=0+1=1 执行一次 n=4执行二次,以此类推336次一个循环 
		while (n --)
		{
			temp = (a*t + b*t1) % 7; // 存要求的值。 
			t1 = t;   
			t = temp;
		}
		
		printf("%d\n", t);
	}
	return 0;
}

给一个链接, 里面有详细的解析:

https://blog.csdn.net/nameofcsdn/article/details/52708270

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值