hdoj 1528Card Game Cheater【贪心】(田忌赛马pro)

Card Game Cheater

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1577    Accepted Submission(s): 831


Problem Description
Adam and Eve play a card game using a regular deck of 52 cards. The rules are simple. The players sit on opposite sides of a table, facing each other. Each player gets k cards from the deck and, after looking at them, places the cards face down in a row on the table. Adam’s cards are numbered from 1 to k from his left, and Eve’s cards are numbered 1 to k from her right (so Eve’s i:th card is opposite Adam’s i:th card). The cards are turned face up, and points are awarded as follows (for each i ∈ {1, . . . , k}):


If Adam’s i:th card beats Eve’s i:th card, then Adam gets one point.


If Eve’s i:th card beats Adam’s i:th card, then Eve gets one point.


A card with higher value always beats a card with a lower value: a three beats a two, a four beats a three and a two, etc. An ace beats every card except (possibly) another ace.


If the two i:th cards have the same value, then the suit determines who wins: hearts beats all other suits, spades beats all suits except hearts, diamond beats only clubs, and clubs does not beat any suit. 

For example, the ten of spades beats the ten of diamonds but not the Jack of clubs. 

This ought to be a game of chance, but lately Eve is winning most of the time, and the reason is that she has started to use marked cards. In other words, she knows which cards Adam has on the table before he turns them face up. Using this information she orders her own cards so that she gets as many points as possible.

Your task is to, given Adam’s and Eve’s cards, determine how many points Eve will get if she plays optimally. 

 

Input
There will be several test cases. The first line of input will contain a single positive integer N giving the number of test cases. After that line follow the test cases.

Each test case starts with a line with a single positive integer k <= 26 which is the number of cards each player gets. The next line describes the k cards Adam has placed on the table, left to right. The next line describes the k cards Eve has (but she has not yet placed them on the table). A card is described by two characters, the first one being its value (2, 3, 4, 5, 6, 7, 8 ,9, T, J, Q, K, or A), and the second one being its suit (C, D, S, or H). Cards are separated by white spaces. So if Adam’s cards are the ten of clubs, the two of hearts, and the Jack of diamonds, that could be described by the line

TC 2H JD
 

Output
For each test case output a single line with the number of points Eve gets if she picks the optimal way to arrange her cards on the table.

 

Sample Input
  
  
3 1 JD JH 2 5D TC 4C 5H 3 2H 3H 4H 2D 3D 4D
 

Sample Output
  
  
1 1 2
 

Source
 

用的贪心给过了,见有的大神用的二分图过的;

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#define inf 0x3f3f3f 
using namespace std;
const int maxn = 1010;
struct card{
	int num, kind;
};
card a[maxn],b[maxn];
char ch[3];
int turn1(char x)
{
	if(x=='A')	return inf;
	else if(x=='T')	return 10;
	else if(x=='J') return 11;
	else if(x=='Q') return 12;
	else if(x=='K') return 13;
	else	return x-'0';
}
int turn2(char x)
{
	if(x=='H')	return 1;
	else if(x=='S')	return 2;
	else if(x=='D')	return 3;
	else	return 4;
}
bool cmp(card a, card b)
{
	if(a.num != b.num)
		return a.num < b.num;
	return a.kind > b.kind;	
}
int main()
{
	int t,i,j,k,n,m;
	scanf("%d", &t);
	while(t--)
	{
		scanf("%d", &n);
		for(i = 0; i < n; i++)
		{
			scanf("%s", ch);
			a[i].num = turn1(ch[0]);
			a[i].kind = turn2(ch[1]);
		}
		for(i = 0; i < n; i++)
		{
			scanf("%s", ch);
			b[i].num = turn1(ch[0]);
			b[i].kind = turn2(ch[1]);
		}
		sort(a, a+n, cmp);
		sort(b, b+n, cmp);
		//接下来仿照田忌赛马过程~ 
		int num = 0;
		int al=0,ah=n-1;  
	    int bl=0,bh=n-1;  
	    while(bl<=bh)  
	    {  
	        if(b[bh].num>a[ah].num||(b[bh].num==a[ah].num&&b[bh].kind<a[ah].kind))  
	        {  
	            ah--;  
	            bh--;  
	            num++;  
	        }  
	        else if(b[bl].num>a[al].num||(b[bl].num==a[al].num&&b[bl].kind<a[al].kind))  
	        {  
	            al++;  
	            bl++;  
	            num++;  
	        }  
	        else if(a[ah].num<b[bl].num||(a[ah].num==b[bl].num&&a[ah].kind>b[bl].kind))  
	        {  
	            num--;  
	            bl++;  
	            ah--;  
	        }  
	        else  
	        {  
	            bl++;  
	            ah--;  
	        }  
		}
		printf("%d\n", num);
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值