UVA642 Word Amalgamation

11 篇文章 0 订阅

题目介绍

In millions of newspapers across the United States there is a word game called Jumble. The object of this game is to solve a riddle, but in order to find the letters that appear in the answer it is necessary to unscramble four words. Your task is to write a program that can unscramble words.

输入

The input contains four parts: 1) a dictionary, which consists of at least one and at most 100 words, one per line; 2) a line containing XXXXXX, which signals the end of the dictionary; 3) one or more scrambled ‘words’ that you must unscramble, each on a line by itself; and 4) another line containing XXXXXX, which signals the end of the file. All words, including both dictionary words and scrambled words, consist only of lowercase English letters and will be at least one and at most six characters long. (Note that the sentinel XXXXXX contains uppercase X’s.) The dictionary is not necessarily in sorted order, but each word in the dictionary is unique.

输出

For each scrambled word in the input, output an alphabetical list of all dictionary words that can be formed by rearranging the letters in the scrambled word. Each word in this list must appear on a line by itself. If the list is empty (because no dictionary words can be formed), output the line “NOT A VALID WORD” instead. In either case, output a line containing six asterisks to signal the end of the list.

输入样例

tarp
given
score
refund
only
trap
work
earn
course
pepper
part
XXXXXX
resco
nfudre
aptr
sett
oresuc
XXXXXX

输出样例

score
******
refund
* * * * **
part
tarp
trap
******
NOT A VALID WORD
******
course
******

思路

这道题的大意就是玩一个游戏,给你的输入乱序单词,直到读取到XXXXXX 就结束,接下来的每行单词去匹配有没有和输入的乱序单词的每个字母频率相同的。如果找到的话,输出所有的乱序单词,如果没有找到的话就输出NOT A VALID WORD

这道题可以通过创建一个map<string, vector>的map,key是出入的乱序单词按字母序排好后的结果。
vector存的是所有的乱序字符串

唯一的坑就是在输出的时候,vector要先按照字典序排序,才可以输出(应为标准答案是按照字典序排序的)。
学习了一下c++的stl.

#include <stdio.h> 
#include <iostream>
#include <string>
#include <algorithm>
#include <map>
#include <vector>

using namespace std;

int main() {

    string word, key;
    map <string, vector<string>> dic;

    while (cin >> word && word != "XXXXXX") {
        key = word;
        sort(key.begin(), key.end());
        dic[key].push_back(word);
    }

    while (cin >> key && key != "XXXXXX") {
        sort(key.begin(), key.end());
        if (dic.count(key) <= 0) {
            cout << "NOT A VALID WORD" << endl;
        } else {
            vector<string> v = dic[key];
            sort(v.begin(), v.end());
            vector<string>::iterator it;
            for (it = v.begin(); it != v.end(); ++it) {
                cout << *it << endl;
            }
        }
        cout << "******" << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值