poj 3278 Catch That Cow

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 47033 Accepted: 14770

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

John农民终于知道那个逃跑的母牛去哪了,并且想赶紧给抓回来。他在点N(0 ≤ N ≤ 100,000),牛在点K (0 ≤ K ≤ 100,000) ,他们都在同一个数轴上。John有两种移动方式:走路和远距离传送。

走路:FJ可以从X移动到X-1和X+1在一分钟内

远距离传送:FJ可以从X移动到2*X在一分钟内

牛,还没意识到自己被跟踪了,根本不动,John多久才能逮到牛?

Input

Line 1: Two space-separated integers:  N and  K
两个数,N和K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
需要的时间

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source


虽然用了BFS不过果然这道题除了二倍就是左右走,最好的办法,还是找到其中的规律。。。这个在discuss里面有,就是对N-K的逆推,效率十分高。。。
下面是BFS版本,需要对边界有点注意,坑了好几次。。。
#include <stdio.h>
#include <string.h>


struct Point{
    int dis;
    int step;
};
int main(void){

    freopen("in.txt", "r", stdin);
    //freopen("out.txt", "w", stdout);
    int head = 0, tail = 1;
    int visit[200004];
    int n, k;
    struct Point fifo[200004];

    scanf("%d%d", &n, &k);
    memset(visit, 0, sizeof(visit));

    visit[n] = 1;
    //printf("%d%d\n", n, k);

    fifo[head].dis = n;
    fifo[head].step = 0;

    while(head <= tail){
        struct Point curr = fifo[head];
        if (curr.dis == k){
            printf("%d\n", fifo[head].step);
            break;
        }

        if ((0 <= curr.dis - 1)  && (visit[curr.dis - 1] == 0)){
            fifo[tail].dis = curr.dis - 1;
            fifo[tail++].step = curr.step + 1;
            visit[curr.dis - 1] = 1;
            printf("tail = %d\n", tail);
        }

        if ((curr.dis <= k)  && (visit[curr.dis + 1] == 0)){//here not corr.dis + 1 <= k;
            fifo[tail].dis = curr.dis + 1;
            fifo[tail++].step = curr.step + 1;
            visit[curr.dis + 1] = 1;
        }

        if ((curr.dis <= k) && (visit[curr.dis * 2] == 0)){//here not corr.dis * 2 <= k;
            fifo[tail].dis = curr.dis * 2;
            fifo[tail++].step = curr.step + 1;
            visit[curr.dis * 2] = 1;
        }
        head ++;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园整体解决方案是响应国家教育信息化政策,结合教育改革和技术创新的产物。该方案以物联网、大数据、人工智能和移动互联技术为基础,旨在打造一个安全、高效、互动且环保的教育环境。方案强调从数字化校园向智慧校园的转变,通过自动数据采集、智能分析和按需服务,实现校园业务的智能化管理。 方案的总体设计原则包括应用至上、分层设计和互联互通,确保系统能够满足不同用户角色的需求,并实现数据和资源的整合与共享。框架设计涵盖了校园安全、管理、教学、环境等多个方面,构建了一个全面的校园应用生态系统。这包括智慧安全系统、校园身份识别、智能排课及选课系统、智慧学习系统、精品录播教室方案等,以支持个性化学习和教学评估。 建设内容突出了智慧安全和智慧管理的重要性。智慧安全管理通过分布式录播系统和紧急预案一键启动功能,增强校园安全预警和事件响应能力。智慧管理系统则利用物联网技术,实现人员和设备的智能管理,提高校园运营效率。 智慧教学部分,方案提供了智慧学习系统和精品录播教室方案,支持专业级学习硬件和智能化网络管理,促进个性化学习和教学资源的高效利用。同时,教学质量评估中心和资源应用平台的建设,旨在提升教学评估的科学性和教育资源的共享性。 智慧环境建设则侧重于基于物联网的设备管理,通过智慧教室管理系统实现教室环境的智能控制和能效管理,打造绿色、节能的校园环境。电子班牌和校园信息发布系统的建设,将作为智慧校园的核心和入口,提供教务、一卡通、图书馆等系统的集成信息。 总体而言,智慧校园整体解决方案通过集成先进技术,不仅提升了校园的信息化水平,而且优化了教学和管理流程,为学生、教师和家长提供了更加便捷、个性化的教育体验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值