Language:
Catch That Cow
Description Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it? Input
Line 1: Two space-separated integers:
N and
K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input 5 17 Sample Output 4 Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
|
农夫抓一只逃跑的牛,假设在一条线上,农夫的位置是 n ,牛的位置是k。农夫有两种移动方式 :
当前农夫是位置是X;
一种是X + 1 或 X - 1 耗时1分钟;另一种是 2*X 耗时也是一分钟;
求最快什么时候抓到牛;
思路:
每次有三种情况,用bfs求解;
AC 代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <vector>
using namespace std;
#define INF 0x7ffffff
#define Maxn 1100005
int n, k;
int d[Maxn];
int bfs(int n, int k){
memset(d, -1, sizeof(d));
queue<int> que;
que.push(n);
d[n] = 0;
while (que.size()){
int cur = que.front(); que.pop();
if (cur == k)
break;
if (cur - 1 >= 0 && d[cur - 1] == -1){
d[cur - 1] = d[cur] + 1;
que.push(cur - 1);
}
if (cur + 1 < Maxn && d[cur + 1] == -1){
d[cur + 1] = d[cur] + 1;
que.push(cur + 1);
}
if (cur * 2 < Maxn && d[cur * 2] == -1){
d[cur * 2] = d[cur] + 1;
que.push(cur * 2);
}
}
return d[k];
}
int main(){
#ifdef LOCAL
freopen("Text.txt", "r", stdin);
#endif
while (scanf("%d%d", &n, &k) == 2){
int ans = bfs(n, k);
printf("%d\n", ans);
}
return 0;
}