hdu1041 Computer Transformation 大数找规律

Computer Transformation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8161    Accepted Submission(s): 3069


Problem Description
A sequence consisting of one digit, the number 1 is initially written into a computer. At each successive time step, the computer simultaneously tranforms each digit 0 into the sequence 1 0 and each digit 1 into the sequence 0 1. So, after the first time step, the sequence 0 1 is obtained; after the second, the sequence 1 0 0 1, after the third, the sequence 0 1 1 0 1 0 0 1 and so on. 

How many pairs of consequitive zeroes will appear in the sequence after n steps? 
 

Input
Every input line contains one natural number n (0 < n ≤1000).
 

Output
For each input n print the number of consecutive zeroes pairs that will appear in the sequence after n steps.
 

Sample Input
 
 
23
 

Sample Output
 
 
11
 
题目大意就是,屏幕上开始是1,以后,1会变成01,0会变成10,最后问每次有多少对0,(两个连续的0算一对),最后可得递推公式f(n)=f(n-1)+2*f(n-2);由于数据过大,需要进行大数处理,故可采用java

import java.util.Scanner;
import java.math.*;
public class Main {
	public static void main(String[] args) {
		Scanner in = new Scanner(System.in);
		BigInteger[] a = new BigInteger[1005];
		a[0]=BigInteger.valueOf(0);
		a[1]=BigInteger.valueOf(0);
		a[2]=BigInteger.valueOf(1);
		for(int i=3;i<1005;i++){
			a[i] = a[i-1].add(a[i-2]).add(a[i-2]);
		}
		int n;
		while(in.hasNext()){
			n = in.nextInt();
			System.out.println(a[n]);
		}
		in.close();
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值