Battle City

文章描述了一个简化版的Battlecity游戏,玩家需在不考虑敌人的情况下,从起点(Y)出发,尽快到达目标(T)。地图由空地、河流、钢墙和砖墙组成,坦克不能穿过河流和钢墙,但能摧毁砖墙。问题转化为求从起点到目标的最短步数。这是一个经典的BFS问题,通过建立优先队列进行广度优先搜索,找到最短路径。当遇到障碍时,若为砖墙,则步数增加2,否则增加1。如果无法到达目标,则输出-1。
摘要由CSDN通过智能技术生成

Many of us had played the game "Battle city" in our childhood, and some people (like me) even often play it on computer now. 


What we are discussing is a simple edition of this game. Given a map that consists of empty spaces, rivers, steel walls and brick walls only. Your task is to get a bonus as soon as possible suppose that no enemies will disturb you (See the following picture). 


Your tank can't move through rivers or walls, but it can destroy brick walls by shooting. A brick wall will be turned into empty spaces when you hit it, however, if your shot hit a steel wall, there will be no damage to the wall. In each of your turns, you can choose to move to a neighboring (4 directions, not 8) empty space, or shoot in one of the four directions without a move. The shot will go ahead in that direction, until it go out of the map or hit a wall. If the shot hits a brick wall, the wall will disappear (i.e., in this turn). Well, given the description of a map, the positions of your tank and the target, how many turns will you take at least to arrive there?

Input

The input consists of several test cases. The first line of each test case contains two integers M and N (2 <= M, N <= 300). Each of the following M lines contains N uppercase letters, each of which is one of 'Y' (you), 'T' (target), 'S' (steel wall), 'B' (brick wall), 'R' (river) and 'E' (empty space). Both 'Y' and 'T' appear only once. A test case of M = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the turns you take at least in a separate line. If you can't arrive at the target, output "-1" instead.

Sample Input

3 4
YBEB
EERE
SSTE
0 0

Sample Output

8

题意:从Y开始移动,如果遇到S或者R不能通过,如果遇到B则时间加2,如果遇到E则时间加1,求到达T的最短时间;

分析如下:

根据要求这也是一道典型的BFS的模板题,我做这道题的时候有个误区,分享一下:

1.根据样例当y向左移动时首先耗费时间为2,因此根据重载函数,y会向下运动同样也是2,到达(1,1)此时同时都是2,这可怎么办,一直在纠结 ,大概半小时以后,明白原来此时第二种情况已经位于优先队列的上层,所以会执行第一种情况,坦克继续向右移动;

代码如下:

#include<iostream>
#include<algorithm>
#include<queue>
#include<cstring>
#include<cmath>
#include<cstdio>
#define ll long long
using namespace std;
const int MAXN=310;
int a1,b1,mex,mey,tx,ty,flag,r[MAXN][MAXN];
char str[MAXN][MAXN];
int r1[2][4]={{0,0,1,-1},{1,-1,0,0}};
struct node{
    int x,y,step;
    bool friend operator<(node a,node b){
        return a.step>b.step;//重载函数
    }
};

void BFS(int mex,int mey){
    priority_queue<node> p;
    flag=0;
    node now,next;
    now.x=mex;
    now.y=mey;
    now.step=0;
    p.push(now);
    while(!p.empty()){
        next=p.top();
        p.pop();
        if(next.x==tx && next.y==ty){
            flag=1;
            break;
        }
        for(int i=0;i<4;i++){
            now.x=next.x+r1[0][i];
            now.y=next.y+r1[1][i];
            if(now.x>=0 && now.x<a1 && now.y>=0 && now.y<b1 && str[now.x][now.y]!='S' && str[now.x][now.y]!='R' && !r[now.x][now.y]){
                if(str[now.x][now.y]=='B'){
                    now.step=next.step+2;
                }
                else{
                    now.step=next.step+1;
                }
                r[now.x][now.y]=1;
                p.push(now);
            }
        }
    }
    if(flag){
        printf("%d\n",next.step);
    }
    else{
        printf("%d\n",-1);
    }
}
int main(){
    while(scanf("%d%d",&a1,&b1)!=EOF&&(a1||b1)){
        memset(r,0,sizeof(r));
        memset(str,0,sizeof(str));
        for(int i=0;i<a1;i++){
            getchar();
            for(int j=0;j<b1;j++){
                scanf("%c",&str[i][j]);
                if(str[i][j]=='Y'){
                    mex=i;
                    mey=j;
                }
                if(str[i][j]=='T'){
                    tx=i;
                    ty=j;
                }
            }
        }
        BFS(mex,mey);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

旺旺的碎冰冰~

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值