Genealogical tree

The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural. 
And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there's nothing to tell about his grandparents!). But if by a mistake first speak a grandson and only than his young appearing great-grandfather, this is a real scandal. 
Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.

Input

The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member's children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may be empty. The list (even if it is empty) ends with 0.

Output

The standard output should contain in its only line a sequence of speakers' numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least one such sequence always exists.

Sample Input

5
0
4 5 1 0
1 0
5 3 0
3 0

Sample Output

2 4 5 3 1

题意:给你五组数据,按顺序依次输出相关联的点。注意输入格式。

这道题有一个坑点,就是要注意输入格式,很多人输出无结果很大的可能就是输入格式设置错误导致的。这是一道典型的拓扑排序题目。用邻接矩阵来存图,用一维数组来存入度为0的点。同时要清空容器。

#include<cstdio>
#include<iostream>
#include<queue>
#include<cstring>
#include<algorithm>
#include<string>
#include<vector>
#define ll long long
using namespace std;
const int MAXN=110;
int a,b,c,d,sum;
int r[MAXN];//记录入度为0的点
vector<int>ve[MAXN];//邻接矩阵
void fb(int a){
    c=0;
    while(c<a){//把所有点找完退出循环
        for(int i=1;i<=a;i++){
            d=0;
            if(r[i]){
                continue;
            }//对入度为0的点直接跳过,减少循环
            for(int j=0;j<ve[i].size()&&!d;j++){
                if(!r[ve[i][j]]){
                    d++;
                }
            }
            if(!d){
                r[i]=1;//标记入度为0的点
                printf("%d ",i);
                c++;
            }
        }
    }
}
int main(){
    scanf("%d",&a);
    for(int i=1;i<=a;i++){
        ve[i].clear();//切记清空容器
        r[i]=0;//同时把所有a范围内的点入度初始化为0
    }
    for(int i=1;i<=a;i++){
        scanf("%d",&b);
        while(b){
            ve[b].push_back(i);//建立邻接矩阵关系存图
            scanf("%d",&b);
        }
    }
    fb(a);
    printf("\n");
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

旺旺的碎冰冰~

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值