[Java] 1002. A+B for Polynomials (25)-PAT甲级

This time, you are supposed to find A+B where A and B are two polynomials.

Input
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2

题目大意:计算A+B的和,A和B都是多项式

PS:感谢github用户@fs19910227提供的pull request~

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;

public class Main {
    static class Polynomial {
        private static int MAX_SIZE = 1001;
        private double[] coefficients;

        Polynomial(String[] splits) {
            coefficients = new double[MAX_SIZE];
            for (int i = 1; i < splits.length; i += 2) {
                int exp = Integer.valueOf(splits[i]);
                coefficients[exp] = Double.valueOf(splits[i + 1]);
            }
        }

        Polynomial() {
            coefficients = new double[MAX_SIZE];
        }

        public Polynomial add(Polynomial other) {
            Polynomial result = new Polynomial();
            for (int i = 0; i < MAX_SIZE; i++) {
                double v = this.coefficients[i] + other.coefficients[i];
                v = Math.round(v * 10) / 10.0;
                if (v != 0.0) {
                    result.coefficients[i] = v;
                }
            }
            return result;
        }

        @Override
        public String toString() {
            StringBuilder stringBuilder = new StringBuilder();
            int size = 0;
            for (int i = coefficients.length - 1; i >= 0; i--) {
                double v = coefficients[i];
                if (v != 0.0) {
                    stringBuilder.append(i).append(" ").append(v).append(" ");
                    size++;
                }
            }
            stringBuilder.insert(0, size + " ");
            stringBuilder.deleteCharAt(stringBuilder.length() - 1);
            return stringBuilder.toString();
        }
    }

    private static BufferedReader reader = new BufferedReader(new InputStreamReader(System.in));

    public static String[] readLine() throws IOException {
        return reader.readLine().split(" ");
    }

    public static void main(String[] args) throws IOException {
        Polynomial add = new Polynomial(readLine()).add(new Polynomial(readLine()));
        System.out.println(add);
    }
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值