1002 A+B for Polynomials (25 分) java

1002 A+B for Polynomials (25 分)
This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N
​1
​​ a
​N
​1
​​
​​ N
​2
​​ a
​N
​2
​​
​​ … N
​K
​​ a
​N
​K
​​
​​

where K is the number of nonzero terms in the polynomial, N
​i
​​ and a
​N
​i
​​
​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N
​K
​​ <⋯<N
​2
​​ <N
​1
​​ ≤1000.

Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 2 1.5 1 2.9 0 3.2

代码:`

import java.util.*;

public class Main {
    public static void main(String[] args) {
        Scanner scanner=new Scanner(System.in);
        int a=scanner.nextInt();
        Map<Integer, Double> map1=new HashMap<Integer, Double>();
        for(int i=0;i<a;i++){
            Integer input=scanner.nextInt();
            if(map1.containsKey(input)){
                map1.put(input,scanner.nextDouble()+map1.get(input));
            }else {
           map1.put(input,scanner.nextDouble());}
        }

        int b=scanner.nextInt();
        for(int i=0;i<b;i++){
            Integer input2=scanner.nextInt();
            if(map1.containsKey(input2)){
                map1.put(input2,scanner.nextDouble()+map1.get(input2));
            }else {
            map1.put(input2,scanner.nextDouble());}
        }
        Set<Integer> set1=map1.keySet();
        Set<Integer> set = new TreeSet<Integer>(new Comparator<Integer>() {
            @Override
            public int compare(Integer o1, Integer o2) {
                return o1<o2?1:-1;
            }


        });

        set.addAll(set1);

        int size=set.size();
        if(size==1){
            for(Integer num:set){
               if(map1.get(num).equals(Double.valueOf(0))){
                   System.out.print("0");
                   return;
               }
            }
        }
        String output="";
        for(Integer num:set){
            if(map1.get(num).equals(Double.valueOf(0))){
                size--;
                continue;
            }
           output+=" "+num+" "+
                    String.format("%.1f",map1.get(num));
        }

        System.out.print(size+output);
    }
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值