HDU 1061 ----Rightmost Digit

Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 40224    Accepted Submission(s): 15191


Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the rightmost digit of N^N.
 

Sample Input
  
  
2 3 4
 

Sample Output
  
  
7 6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
 

Author
Ignatius.L



/* 需要寻找规律
(0)1~9 是一个与十位(为偶数)相关的循环 10~19是与十位(为奇数)有关的循环。
还要额外判断十位为0的情况。也没必要用__int64,关于此下面代码未作修改。

*/
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;



int main()
{
    __int64 T,n,t;
    while(scanf("%I64d",&T)!=-1){

            for(__int64 i=0;i<T;i++){
                __int64 mul=1;

            scanf("%I64d",&n);
            t=n;
            t = t/10%10;
            //printf("t:%d\n",t);
        if(n>20&&t!=0){

                    if(t%2==0)
                        n = n%10;
                    else{
                        n = n%10;
                        n += 10;
                    }
                }
                else
                    n=n%10;

        if(n==0) mul=0;
            for(__int64 j=1;j<=n;j++){
                mul *= n;
                if(mul>10)
                mul = mul%10;
            }
            printf("%lld\n",mul);
        }



    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值