HDU-1061-Rightmost Digit

Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 33177    Accepted Submission(s): 12701


Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the rightmost digit of N^N.
 

Sample Input
  
  
2 3 4
 

Sample Output
  
  
7 6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
以前做的,之前没做出来,直接用的循环,TLE了,应该是常理之中吧,然后现在想想这种题就是要去找规律的,突然发现自己进步了不少,这题放在以前都不知道会从这种方面想。
要输出最右边一位,并且是N^N的最右一位,
先举出一下例子,如11, 以1结尾,乘多少次都是1, 同样的还有0, 5 , 6。
其他的也有规律,他们乘以好多次都会回到原来的数,如7 : 7 -〉 9 -〉 3 -〉 1 -〉 7 就是这个规律了。
这题还是很水的,贴个代码:
#include <cstdio>
#include <cstring>
using namespace std;

int main()
{
    int T, s, N;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&N);
        s=N%10;
        if(s == 0 || s == 1 || s == 5 || s == 6)
        {
        	printf("%d\n", s);
        }
        else if(s == 2)
        {
        	if(N%4==1)printf("2\n");
        	if(N%4==2)printf("4\n");
        	if(N%4==3)printf("8\n");
        	if(N%4==0)printf("6\n");
        }
        else if(s == 3)
        {
        	if(N%4==1)printf("3\n");
        	if(N%4==2)printf("9\n");
        	if(N%4==3)printf("7\n");
        	if(N%4==0)printf("1\n");
        }
        else if(s == 4)
        {
        	if(N%2==1)printf("4\n");if(N%2==0)printf("6\n");
        }
        else if(s == 7)
        {
        	if(N%4==1)printf("7\n");if(N%4==2)printf("9\n");
        	if(N%4==3)printf("3\n");if(N%4==0)printf("1\n");
        }
        else if(s == 8)
        {
        	if(N%4==1)printf("8\n");if(N%4==2)printf("4\n");
        	if(N%4==3)printf("2\n");if(N%4==0)printf("6\n");
        }
        else if(s == 9)
        {
        	if(N%2==1)printf("9\n");
        	if(N%2==0)printf("1\n");
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值