【杭电1213】How Many Tables

How Many Tables
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers. 

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table. 

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least. 

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases. 

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks. 

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output

2
4
已知会告诉你各个独立集的关系,通过这些关系的作用之后,会留下多少个独立的集合!
根据已知条件我们可以讲有关系的集合进行合并,最后看谁的祖先是本身,就说明它将是一个独立集!
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
#include<stdio.h>
#include<algorithm>
using namespace std;
int f[1100];
int findroot(int x)
{
	int r=x;
	while(r!=f[r])
	r=f[r];
	int i=x,j;
	while(i!=r)
	{
		j=f[i];
		f[i]=r;
		i=j;
	}
	return r;
}
int main()
{
	int t,b,a,n,m;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		for(int i=1;i<=n;i++)
		f[i]=i;
		for(int i=0;i<m;i++)
		{
			scanf("%d%d",&a,&b);//a与b认识,如果根节点不同,合并两个集合,即成为一桌
			int xx=findroot(a);
			int yy=findroot(b);
			if(xx!=yy)
			f[xx]=yy;
		}
		int num=0;
		for(int j=1;j<=n;j++)
		{
			if(f[j]==j)
			num++;
		}
		printf("%d\n",num);
	}
	return 0;
}
与1232题畅通工程雷同,只需稍作修改
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
#include<stdio.h>
#include<algorithm>
using namespace std;
int f[1100];
int find(int x)
{
	int r=x;
	while(r!=f[r])
	r=f[r];
	int i=x,j;	
	while(i!=r)
	{
		j=f[i];
		f[i]=r;
		i=j;
	}
	return r;
}
void unio(int a,int b)
{
	int nx=find(a);
	int ny=find(b);
	if(nx!=ny)
	f[ny]=nx;
}
int main()
{
	int n,m,a,b,k;
	scanf("%d",&k);
	while(k--)
	{
	scanf("%d%d",&n,&m);
		for(int i=1;i<=n;i++)
		f[i]=i;
		for(int i=0;i<m;i++)
		{
			scanf("%d%d",&a,&b);
			unio(a,b);
		}
		int t=0;
		for(int i=1;i<=n;i++)
		{
			if(f[i]==i)
			t++;
		}
	printf("%d\n",t);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值