Poj 2253 Frogger【最小生成树(巧解)】


Frogger
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 30450 Accepted: 9812

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

题意:

说的是,两个青蛙分别在一个水池中的两个石头上,一个青蛙想去找另一只青蛙,但是她不想游泳(这还是青蛙吗),然后就借助别的石头跳啊跳,问他最远一次至少要要跳多远能让他到达目的地,第一个坐标是起点,第二个坐标是终点,其他的位置是别的石头坐标


题解:

贪心加最小生成树的题目,第一眼看到的时候,还以为是最短路,后来朋友说可以用并查集,然后介绍给我一种很好的方法,当时就感觉很巧妙,就试着做了,挺好的

用的是并查集的最小生成树的思想:在生成树的时候,每次都判断和更新起点和终点是否相连,如果相连,那么这条边就是所求的,因为这条边肯定是已加入集合里最长的距离,否则的话,就继续更新状态,就这样持续生成树,一直到起点和终点相连,就得到需要的数据了


#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;
int per[205],n,t=0;
double a[205],b[205];
struct lu
{
	int a,b;
	double len;
}x[250005];//尽量开大点
double dis(int i,int j)
{
	return sqrt((a[i]-a[j])*(a[i]-a[j])*1.0+(b[i]-b[j])*(b[i]-b[j]));//求距离
}
void init()
{
	for(int i=1;i<=n;++i)
	{
		per[i]=i;
	}
}
bool cmp(lu a,lu b)
{
	return a.len<b.len;
}
int find(int x)
{
	int r=x;
	while(r!=per[r])
	{
		r=per[r];
	}
	int i=x,j;
	while(i!=r)
	{
		j=per[i];per[i]=r;i=j;
	}
	return r;
}
int join(int x,int y)
{
	int fx=find(x),fy=find(y);
	if(fx!=fy)
	{
		per[fy]=fx;
		return 1;
	}
	return 0;
}
void kruskal()
{
	int cnt=0;double maxn=0;
	for(int i=0;cnt<n-1;++i)
	{
		if(join(x[i].a,x[i].b))
		{
			if(find(1)==find(2))//这里很巧妙
			{
				maxn=x[i].len;//找到就赋值
				break;//跳出循环,加快速度
			}
			++cnt;//每次统计边数
		}
	}
	printf("Scenario #%d\nFrog Distance = %.3f\n\n",++t,maxn);//注意输出格式
}
int main()
{
	int i,j;
	while(scanf("%d",&n),n)
	{
		init();
		for(i=0;i<n;++i)
		{
			scanf("%lf%lf",a+i,b+i);
		}
		int c=0;
		for(i=0;i<n-1;++i)
		{
			for(j=i+1;j<n;++j)//双循环把所有的顶点和边保存
			{
				x[c].a=i+1;x[c].b=j+1;
				x[c].len=dis(i,j);
				++c;
			}
		}
		sort(x,x+c,cmp);//排序
		kruskal();
	}
	return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值