Poj 3320 Jessica's Reading Problem【动态尺取法】

Jessica's Reading Problem
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9448 Accepted: 3079

Description

Jessica's a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.

A very hard-working boy had manually indexed for her each page of Jessica's text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.

Input

The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica's text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.

Output

Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.

Sample Input

5
1 8 8 8 1

Sample Output

2

说的是一列连续的数字,需要找到一连续的子序列,包含这个序列中所有类型的数字,求这个子序列的最短长度

原本自己理解错了,本来以为直累加,然后进行尺取法尽可以了,结果后来自己想得太简单了....

这算是个动态问题,感觉这些问题解决的都比较灵活,慢慢学吧!


#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<set>
#include<map>
using namespace std;
int n,x[1000005];
int slove()
{
	set<int> set;
	for(int i=0;i<n;++i)
	{
		set.insert(x[i]);
	}
	int num=set.size(),len=n,cnt=0,bg=0,ed=0;
	/*
	num 是总的元素种类,len 是需要求的最短长度,
	cnt 是当前长度包含元素的种类数,bg 是起点,ed 是终点 
	*/
	map<int,int> map;
	while(1)
	{
		while(cnt<num&&ed<n)
		{
			if(map[x[ed]]==0)//新的种类 
			{
				++cnt;
			}
			++map[x[ed]];++ed;//结束位置后移 
		}
		if(cnt<num)//这种情况只会在判断结束时出现 
		{
			break;
		}
		len=min(len,ed-bg);//动态更新 
		--map[x[bg]]; //起始位置后移
		if(map[x[bg]]==0)//种类减少的话 
		{
			--cnt;
		}
		++bg;
	}
	return len;
}
int main()
{
	while(~scanf("%d",&n))
	{
		for(int i=0;i<n;++i)
		{
			scanf("%d",&x[i]);
		}
		printf("%d\n",slove());
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值