Jessica's Reading Problem POJ - 3320(尺取法)

Jessica’s a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.

A very hard-working boy had manually indexed for her each page of Jessica’s text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.

Input
The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica’s text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.

Output
Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.

Sample Input
5
1 8 8 8 1
Sample Output
2
昨天codeforces C题是考察尺取法的,但是这一块不大熟悉,搞点题练练。
思路:这算是一个比较基础的尺取法的题目了。尺取法就是两个指针,来回搞。比起双重循环快了很多很多。我们首先移动右指针,直到数量达到所有知识点的数量。然后移动左指针,不断地更新最小值,直到知识点的数量少于所有的知识点的数量。
代码如下:

#include<iostream>
#include<cstdio>
#include<map> 
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;

const int maxx=1e6+100;
int a[maxx];
int n;

int main()
{
	scanf("%d",&n);
	map<int,int> mp;
	int cnt=0;
	for(int i=1;i<=n;i++)
	{
		scanf("%d",&a[i]);
		if(mp[a[i]]==0) mp[a[i]]=1,cnt++;
	}
	int l=1,r=1;
	mp.clear();
	int sum=0;
	int _max=inf;
	while(r<n)
	{
		while(sum<cnt&&r<=n) 
		{
			if(mp[a[r]]==0) sum++;
			mp[a[r]]++;
			r++;
		}
		r--;
		while(sum==cnt)
		{
			_max=min(_max,r-l+1);
			mp[a[l]]--;
			if(mp[a[l]]==0) sum--;
			l++;
		}
		r++;
	}
	printf("%d\n",_max);
	return 0;
}

努力加油a啊,(o)/~

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

starlet_kiss

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值