Poj 2229 Sumsets【dp】

Sumsets
Time Limit: 2000MS Memory Limit: 200000K
Total Submissions: 15692 Accepted: 6243

Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7: 

1) 1+1+1+1+1+1+1 
2) 1+1+1+1+1+2 
3) 1+1+1+2+2 
4) 1+1+1+4 
5) 1+2+2+2 
6) 1+2+4 

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000). 

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6

Source


题意:

给出一个数,问这个数能拆分成多少种完全由2 的次幂构成的数字的和


题解:

1,n 为奇数时,相对于n-1 的情况,只是把每种情况的等式上+1,并没有改变等式的个数

2,n 为偶数时,首先相对于n-1 的情况,只是每个式子多加了1,全部算上,另外,在分配的时候,并不分含有 1 的情况,这种情况的个数便是n/2对应的数量。


说实话,自己也不是太理解,大概是这样理解的了....


/*
http://blog.csdn.net/liuke19950717
*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
const ll maxn=1000005;
ll dp[maxn],mod=1e9;
int main()
{
    dp[1]=1;dp[2]=2;
    for(ll i=3;i<maxn;i+=2)
    {
        dp[i]=dp[i-1];//奇数不变
        dp[i+1]=(dp[i]+dp[(i+1)/2])%mod;//偶数加上
    }
    ll n;
    while(~scanf("%lld",&n))
    {
        printf("%lld\n",dp[n]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值