POJ 2229 Sumsets 【规律题】

http://poj.org/problem?id=2229


Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7: 

1) 1+1+1+1+1+1+1 
2) 1+1+1+1+1+2 
3) 1+1+1+2+2 
4) 1+1+1+4 
5) 1+2+2+2 
6) 1+2+4 

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000). 

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6
//因为每个加数都应该2的n次方,规律挺好找的,可以分两种情况:

当N为奇数的时候: 就等于上一个数+1即fun[N]=fum[N-1];//这个比较好理解

当N为偶数的时候:首先想到的也是上一个数+1就行了,但这里还要考虑加数没有1的情况,N拆成N/2+N/2的情况,对应的结果也就是fun[N]=fun[N-1]+fun[N/2];

#include <stdio.h>
#include <string.h>
int a[1000000+10];
void fun(int N)
{
	a[1]=1;a[2]=2;
	for(int i=3;i<=N;++i)
	{
		if(i&1) a[i]=a[i-1];
		else a[i]=a[i-1]+a[i/2];
		a[i]%=1000000000;
	}
}
int main()
{
	int N;
	while(~scanf("%d",&N))
	{
		fun(N);
		printf("%d\n",a[N]);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值