POJ 2229 Sumsets 解题报告 动态规划

Description
Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

  1. 1+1+1+1+1+1+1
  2. 1+1+1+1+1+2
  3. 1+1+1+2+2
  4. 1+1+1+4
  5. 1+2+2+2
  6. 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).
Input
A single line with a single integer, N.
Output
The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).
Sample Input
7
Sample Output
6

题目大意:
给出一个整数n,求解该整数n有多少种由2的幂次之和组成的方案

解题思路:
2的次幂除1外均为偶数,那么便可以根据分解的结果含不含1来讨论:
1、如果n为奇数,则分解结果必定含1,将所有的分解结果中的1去掉,就变成了 n-1的分解, 即//若n为奇数 则 dp[n] = dp[n-1]
2、若n为偶数,则 //对于分解结果含1的情况,去掉1,就变成了dp[n-1] //对于分解因子全为偶数的情况,分解因子都除以2,就变成了dp[n/2] 即dp[i] = dp[i - 1] + dp[i / 2]);

AC代码

#include<iostream>
using namespace std;
int dp[1000001];
int main() {
	dp[1] = 1;
	for (int i = 2; i <= 1000000; i++) {
		if (i % 2 == 1) { dp[i] = dp[i - 1]; }
		else dp[i] = (dp[i - 1] + dp[i / 2]) % 1000000000;
	}
	int n;
	while (cin >> n) {
		cout << dp[n] << endl;
	}
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值