Poj 1742 Coins【多重背包】

Coins
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 33126 Accepted: 11253

Description

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch. 
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins. 

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4

Source


题意:

给出若干个数字以及每个数字的个数,不能分割,问能拼凑出多少个位于1-sum(数字总和)的数字。


题解:

竟然是完全背包问题,对于我这种01背包都没能完全弄明白的人来说,多重背包就根本不知道在说什么了..........


大概理解了一下,用dp 数组来进行各个物品的选取,sum 数组来记录所有出现的可能性,以及每个元素使用的数量


其他的看代码自己理解吧....囧,慢慢理解吧!


#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int val[105],num[105];
int slove(int n,int m)
{
    int dp[100005]={1},ans=0;
    for(int i=0;i<n;++i)
    {
        int sum[100005]={0};
        for(int j=val[i];j<=m;++j)
        {
            if(!dp[j]&&dp[j-val[i]]&&sum[j-val[i]]<num[i])
            {
                dp[j]=1;++ans;
                sum[j]=sum[j-val[i]]+1;
            }
        }
    }
    return ans;
}
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m),n|m)
    {
        for(int i=0;i<n;++i)
        {
            scanf("%d",&val[i]);
        }
        for(int i=0;i<n;++i)
        {
            scanf("%d",&num[i]);
        }
        printf("%d\n",slove(n,m));
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值