hdu 2852(树状数组+二分)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2852

KiKi's K-Number

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2668    Accepted Submission(s): 1227


Problem Description
For the k-th number, we all should be very familiar with it. Of course,to kiki it is also simple. Now Kiki meets a very similar problem, kiki wants to design a container, the container is to support the three operations.

Push: Push a given element e to container

Pop: Pop element of a given e from container

Query: Given two elements a and k, query the kth larger number which greater than a in container;

Although Kiki is very intelligent, she can not think of how to do it, can you help her to solve this problem?
 

Input
Input some groups of test data ,each test data the first number is an integer m (1 <= m <100000), means that the number of operation to do. The next m lines, each line will be an integer p at the beginning, p which has three values:
If p is 0, then there will be an integer e (0 <e <100000), means press element e into Container.

If p is 1, then there will be an integer e (0 <e <100000), indicated that delete the element e from the container  

If p is 2, then there will be two integers a and k (0 <a <100000, 0 <k <10000),means the inquiries, the element is greater than a, and the k-th larger number.
 

Output
For each deletion, if you want to delete the element which does not exist, the output "No Elment!". For each query, output the suitable answers in line .if the number does not exist, the output "Not Find!".
 

Sample Input
  
  
5 0 5 1 2 0 6 2 3 2 2 8 1 7 0 2 0 2 0 4 2 1 1 2 1 2 2 1 3 2 1 4
 

Sample Output
  
  
No Elment! 6 Not Find! 2 2 4 Not Find!
 

Source
 思路:运用树状数组动态维护一段区间和的特性~每当添加一个数的时候,就在这个数的位置上加一,表示元素的个数多了一个,同理每当要删除一个元素的时候,就在这个元素位置上减一,表示元素的个数减少一个;最后要在大于a的所有元素中找第k大的数,这个时候就要二分来查找~
PS:我的二分写的有点奇葩,调试了好半天才过~
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <string>
#include <cstdio>
#include <cmath>
const int N=1e5+100;
const int M=1e5+10;
using namespace std;
int c[N],m;

int lowbit(int x)
{
  return x&(-x);
}

void update(int x,int d)
{
  while(x<=M)
  {
    c[x]+=d;
    x+=lowbit(x);
  }
}

int getsum(int x)
{
  int ans=0;
  while(x>0)
  {
    ans+=c[x];
    x-=lowbit(x);
  }
  return ans;
}

int find(int a,int k)
{
    int ct=getsum(a);
    int l=a+1,r=M;
    while(l<=r)
    {
     int mid=(l+r)/2;
     int sum=getsum(mid);

     if(sum-ct==k)
     {
      if(getsum(mid-1)-ct<k) return mid;
      else r=mid-1;
     }
     else if(l==r&&sum-ct>k)return l;
     else if(sum-ct<k) l=mid+1;
     else if(sum-ct>k) r=mid-1;

    }

    if(getsum(min(l,r))-ct>k)return min(l,r);
    if(getsum(max(l,r))-ct>k)return max(l,r);
    return 0;
}

int main()
{
   int option,e,a,k;
   while(scanf("%d",&m)!=EOF)
   {
     memset(c,0,sizeof(c));

     for(int i=0;i<m;i++)
     {
      scanf("%d",&option);
      if(option==0)
      {
       scanf("%d",&e);
       update(e,1);
      }
      else if(option==1)
      {
       scanf("%d",&e);
       if(getsum(e)-getsum(e-1)==0)
       {
         printf("No Elment!\n");
         continue;
       }
       update(e,-1);
      }
      else if(option==2)
      {
        scanf("%d%d",&a,&k);
        int temp=find(a,k);
        if(temp==0)
        {
          printf("Not Find!\n");
        }
        else printf("%d\n",temp);
      }
     }
   }
   return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值