Pod 在 Mac OS 新系统 Ventura 的使用问题

Mac OS 更新到 Ventura 后,在 使用 pod 生成工程时出现类似以下警告信息:

Ignoring ffi-1.15.5 because its extensions are not built. Try: gem pristine ffi --version 1.15.5

这主要是因为系统自带的Ruby太旧了,而且新系统可能也将不再自嵌Ruby 等脚本语言。

image-20221101153511248

再看看国外网友怎么说: Do Not Use the MacOS System Ruby

解决方法:

  1. 卸载旧的 Cocoapods

    sudo gem uninstall -n cocoapods
    
  2. 安装 RVM

    \curl -sSL https://get.rvm.io | bash -s stable
    
  3. 安装 Ruby 2.7

    rvm install ruby-2.7
    
  4. 切换到Ruby 2.7.6

    上面安装成功后,ruby默认使用的还是macOS系统自带的版本,需要切换到新安装的版本。

    rvm use ruby-2.7.6
    

    切换后校验版本号

    ruby -v
    

    可以通过查看 ruby 的当前文件位置,确认是否使用的新安装的版本,而不是系统自带的版本。同时,也可以将取得的文件路径配置到环境变量中。

    which ruby
    

    系统自带ruby的路径为/usr/bin/ruby,通过RVM 安装的ruby 路径为~/.rvm/rubies/ruby-2.7.6/bin/ruby

  5. 设置默认的Ruby版本,避免每次启动终端都需要重新切换Ruby(可能需要在安装ruby之后重启终端才能执行成功)。

    rvm --default use 2.7.6
    
  6. 安装 Cocoapods

    sudo gem install -n /usr/local/bin cocoapods
    

    安装完成后,校验版本号

    pod --version
    
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值