An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.
In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.
Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. "O p" (1 <= p <= N), which means repairing computer p.
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.
The input will not exceed 300000 lines.
Output
For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.
Sample Input
4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4
Sample Output
FAIL
SUCCESS
N台损坏的电脑,并且知道其坐标x,y还有两台正常工作的电脑能够进行童心的最大距离d
现有两种操作 O x 修好x*******S a b判断a,b能否通信 能则输出success 否则输出fail
简单的并查集 o就进行合并 s 就进行查询
#include<cstdio>
#include<algorithm>
#include<iostream>
using namespace std;
int pre[1111];
int n,d;
int v[1111];
int x[1111],y[1111];
int Find(int x)
{
int r = x;
while(r!=pre[r])
r = pre[r];
int i = x,j;
while(pre[i]!=r)
{
j = pre[i];
pre[i] = r;
i = j;
}
return r;
}
void mix(int x,int y)
{
int fx = Find(x);
int fy = Find(y);
if(fx!=fy)
pre[fx] = fy;
}
int check(int a,int b)
{
if((x[a]-x[b])*(x[a]-x[b]) + (y[a]-y[b])*(y[a]-y[b]) <= d*d)
return true;
return false;
}
int main()
{
scanf("%d%d",&n,&d);
for(int i = 1; i <= n; i++)
{
v[i] = 0;
pre[i] = i;
}
for(int i = 1; i <= n; i++)
scanf("%d%d",&x[i],&y[i]);
char c;
while(cin>>c)
{
if(c == 'O')
{
int a1;
scanf("%d",&a1);
v[a1] = 1;
for(int i = 1; i <= n; i++)
{
if(v[i] && i!=a1 && check(i,a1))
mix(i,a1);
}
}
if(c == 'S')
{
int w1,w2;
scanf("%d%d",&w1,&w2);
w1 = Find(w1);
w2 = Find(w2);
if(w1 == w2)
printf("SUCCESS\n");
else
printf("FAIL\n");
}
}
return 0;
}