ZOJ 3551 Bloodsucker

A - Bloodsucker
Time Limit:2000MS    Memory Limit:65536KB    64bit IO Format:%lld & %llu

Description

In 0th day, there are n-1 people and 1 bloodsucker. Every day, two and only two of them meet. Nothing will happen if they are of the same species, that is, a people meets a people or a bloodsucker meets a bloodsucker. Otherwise, people may be transformed into bloodsucker with probability p. Sooner or later(D days), all people will be turned into bloodsucker. Calculate the mathematical expectation ofD.

Input

The number of test cases (T, T ≤ 100) is given in the first line of the input. Each case consists of an integern and a float number p (1 ≤ n < 100000, 0 < p ≤ 1, accurate to 3 digits after decimal point), separated by spaces.

Output

For each case, you should output the expectation(3 digits after the decimal point) in a single line.

Sample Input

1
2 1

Sample Output

1.000


概率DP

设dp[i]表示从第i个人到所有人变成吸血鬼的期望(平均值)。

则dp[n]=0。(n个人全都是吸血鬼了,那么平均变0次)

开始逆推。

dp[i]=(dp[i+1]+1)*p1+(dp[i]+1)*(1-p1)
第i个人到所有人变成吸血鬼的期望等于两个期望的和。
当第i个人与吸血鬼相遇时。
有p1的概率变成吸血鬼。p1的值可通过排列组合得到。从n个人里选两个人的方法数有n*(n-1)/2种,其中如果是人和吸血鬼相遇的方法种数有i*(n-i)种。
那么n个人中人和吸血鬼相遇的概率为 ((double)i*(n-i))/((double)n*(n-1)*0.5)
进一步得到n个人中,人和吸血鬼相遇并且人变成吸血鬼的概率p1为
double p1=((double)i*(n-i))/((double)n*(n-1)*0.5)*p;
接着
dp[i]可分为两部分(全期望公式),如果第i个人变成了吸血鬼,那么期望便是,从第i+1人到所有人的期望+1(第i个人自己)再乘以变吸血鬼的概率p1.如果第i个人没变成吸血鬼,期望是从第i个人到所有人变吸血鬼期望+1,再乘上不变吸血鬼的概率(1-p1).
最终dp[1]便是答案。


#include <stdio.h>
#define N 100005
double dp[N];
int main()
{
        int t;
        scanf("%d",&t);
        while(t--)
        {
                int n;
                double p;
                scanf("%d%lf",&n,&p);
                dp[n]=0;
                for(int i=n-1;i>=1;i--)
                {
                        double p1=((double)i*(n-i))/((double)n*(n-1)*0.5)*p;
                        dp[i] = (dp[i+1]*p1+1)/p1;
                }
                printf("%.3lf\n",dp[1]);
        }
        return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值