HDU 2298 Toxophily

B - Toxophily
Time Limit:1000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u

Description

The recreation center of WHU ACM Team has indoor billiards, Ping Pang, chess and bridge, toxophily, deluxe ballrooms KTV rooms, fishing, climbing, and so on.
We all like toxophily.

Bob is hooked on toxophily recently. Assume that Bob is at point (0,0) and he wants to shoot the fruits on a nearby tree. He can adjust the angle to fix the trajectory. Unfortunately, he always fails at that. Can you help him?

Now given the object's coordinates, please calculate the angle between the arrow and x-axis at Bob's point. Assume that g=9.8N/m.
 

Input

The input consists of several test cases. The first line of input consists of an integer T, indicating the number of test cases. Each test case is on a separated line, and it consists three floating point numbers: x, y, v. x and y indicate the coordinate of the fruit. v is the arrow's exit speed.
Technical Specification

1. T ≤ 100.
2. 0 ≤ x, y, v ≤ 10000.
 

Output

For each test case, output the smallest answer rounded to six fractional digits on a separated line.
Output "-1", if there's no possible answer.

Please use radian as unit.
 

Sample Input

     
     
3 0.222018 23.901887 121.909183 39.096669 110.210922 20.270030 138.355025 2028.716904 25.079551
 

Sample Output

     
     
1.561582 -1 -1
 


第一次做的时候觉得这就是到物理题。高中时很简单的那种。

运动的分解。

题目大意:Bob在(00)点想射在(x, y)点的水果,初始的速度为v(已知), g=9.8, 求最小的角度射到苹果.
随便找个高中生都会做吧。

X方向上匀速直线运动,Y方向上竖直上抛运动。

根据运动学公式,可以推得一个方程。

g*x*x*tan^2θ-2*v*v*x*tanθ+g*x*x+2*v*v*y=0

将变量视为tanθ,一元二次方程有木有呀。

求根公式一套。AC了。


#include <stdio.h>
#include <math.h>
#define pi acos(-1)
#define g 9.8
int main()
{
        int t;
        scanf("%d",&t);
        while(t--)
        {
                double x, y, v;
                scanf("%lf%lf%lf",&x,&y,&v);
                double a=g*x*x, b=-2*v*v*x, c=2*v*v*y+g*x*x;
                double delta=b*b-4*a*c;
                if(delta<0)
                        printf("-1\n");
                else
                {
                        double x1=atan((-1*b+sqrt(delta))/(2*a));
                        double x2=atan((-1*b-sqrt(delta))/(2*a));
                        if((x1<0||x1>pi/2)&&(x2<0||x2>pi/2))
                                printf("-1\n");
                        else if(x1<0||x1>pi/2)
                                printf("%.6lf\n", x2);
                        else if(x2<0||x2>pi/2)
                                printf("%.6lf\n", x1);
                        else
                                printf("%.6lf\n", x1>x2?x2:x1);
                }
        }
        return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值