A == B ?

A == B ?

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 104450    Accepted Submission(s): 16623


Problem Description
Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".
 

Input
each test case contains two numbers A and B.
 

Output
for each case, if A is equal to B, you should print "YES", or print "NO".
 

Sample Input
  
  
1 2 2 2 3 3 4 3
 

Sample Output
  
  
NO YES YES NO
 

Author
8600 && xhd
 

Source
 

Recommend
linle   |   We have carefully selected several similar problems for you:   1002  2053  2056  2050  1096 
#include <iostream>
#include <string>

using namespace std;

void change(string &str)
{
    if (str.find('.') != string::npos)
    {
        int last = str.size();
        while (str[--last] == '0')
            str.erase(last, 1);
        if (str[last] == '.')
            str.erase(last, 1);
    }
    while (str[0] == '0')
    {
        if (str.length() != 1)
            str.erase(0, 1);
        else
            return;
    }
}
int main()
{
    string a, b;
    while (cin >> a >> b)
    {
        change(a);
        change(b);
        if (a == b) cout << "YES" << endl;
        else cout << "NO" << endl;
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值