Who's in the Middle
Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11821
Accepted Submission(s): 5595
Problem Description
FJ is surveying his herd to find the most average cow. He wants to know how much milk this ‘median’ cow gives: half of the cows give as much or more than the median; half give as much or less.
Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.
Input
* Line 1: A single integer N
- Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.
Output
* Line 1: A single integer that is the median milk output.
Sample Input
5
2
4
1
3
5
Sample Output
3
Hint
INPUT DETAILS:
Five cows with milk outputs of 1..5
OUTPUT DETAILS:
1 and 2 are below 3; 4 and 5 are above 3.
// 排序c++
#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
int a[10001];
int main()
{
int n;
while(~scanf("%d",&n))
{
int i;
for(i=0;i<n;i++)
scanf("%d",&a[i]);
sort(a,a+n);
printf("%d\n",a[n>>1]);
}
return 0;
}
//排序java
import java.util.Arrays;
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner in=new Scanner(System.in);
while(in.hasNext())
{
int n=in.nextInt(),a[]=new int[n];
for(int i=0;i<n;i++)
a[i]=in.nextInt();
Arrays.sort(a);
System.out.println(a[n/2]);
}
}
}
//快排思想
#include<iostream>
#include<cstdio>
using namespace std;
int fang(int a[],int l,int r)
{
int k=0;
int i=l,j=r,mid=(l+r)/2;
while(1)
{
int temp=a[l];
while(i<j)
{
for(; i<j; j--)
if(a[j]<temp)
{
a[j]^=a[i]^=a[j]^=a[i];
i++;
break;
}
for(; i<j; i++)
if(a[i]>temp)
{
a[i]^=a[j]^=a[i]^=a[j];
j--;
break;
}
}
a[i]=temp;
if(i==mid) break;
if(i<mid)
{
l=i=i+1;
j=r;
}
if(i>mid)
{
r=j=i-1;
i=l;
}
}
printf("%d\n",a[mid]);
}
int main()
{
int a[10001];
int n,i,l,r;
while(~scanf("%d",&n))
{
for(i=0; i<n; i++)
scanf("%d",&a[i]);
fang(a,0,n-1);
}
return 0;
}