HDU 1157 POJ 2388 Who's in the Middle 求中位数

1 篇文章 0 订阅
                        Who's in the Middle

                Time Limit: 2000/1000 MS (Java/Others)    
                Memory Limit: 65536/32768 K (Java/Others)
                Total Submission(s): 11821    
                Accepted Submission(s): 5595

Problem Description
FJ is surveying his herd to find the most average cow. He wants to know how much milk this ‘median’ cow gives: half of the cows give as much or more than the median; half give as much or less.

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.

Input
* Line 1: A single integer N

  • Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.

Output
* Line 1: A single integer that is the median milk output.

Sample Input
5
2
4
1
3
5

Sample Output
3

Hint

INPUT DETAILS:

Five cows with milk outputs of 1..5

OUTPUT DETAILS:

1 and 2 are below 3; 4 and 5 are above 3.

// 排序c++
#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
int a[10001];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        int i;
        for(i=0;i<n;i++)
            scanf("%d",&a[i]);
        sort(a,a+n);
        printf("%d\n",a[n>>1]);
    }
    return 0;
}
//排序java
import java.util.Arrays;
import java.util.Scanner;
public class Main {
    public static void main(String[] args) {
        Scanner in=new Scanner(System.in);
        while(in.hasNext())
        {
            int n=in.nextInt(),a[]=new int[n];
            for(int i=0;i<n;i++)
               a[i]=in.nextInt();
            Arrays.sort(a);
            System.out.println(a[n/2]);    
        }
    }    
}
//快排思想
#include<iostream>
#include<cstdio>
using namespace std;
int fang(int a[],int l,int r)
{
    int k=0;
    int i=l,j=r,mid=(l+r)/2;
    while(1)
    {
        int temp=a[l];
        while(i<j)
        {
            for(; i<j; j--)
                if(a[j]<temp)
                {
                    a[j]^=a[i]^=a[j]^=a[i];
                    i++;
                    break;
                }
            for(; i<j; i++)
                if(a[i]>temp)
                {
                    a[i]^=a[j]^=a[i]^=a[j];
                    j--;
                    break;
                }
        }
        a[i]=temp;
        if(i==mid) break;
        if(i<mid)
        {
            l=i=i+1;
            j=r;
        }
        if(i>mid)
        {
            r=j=i-1;
            i=l;
        }
    }
    printf("%d\n",a[mid]);
}
int main()
{
    int a[10001];
    int n,i,l,r;
    while(~scanf("%d",&n))
    {
        for(i=0; i<n; i++)
            scanf("%d",&a[i]);
        fang(a,0,n-1);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值