poj-Wormholes

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1…N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself ? .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.
Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2… M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2… M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output
Lines 1… F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).
Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint
For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
代码分析:是否存在负环(spfa只能判断有无负环,但是不能处理负环)
AC代码:

//poj-Wormholes(判断负环)
//#include<bits/stdc++.h> poj不支持。。。。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<vector> 
#define INF 0x7f7f7f7f
#define N 2600
using namespace std;
struct Edge{
	int v,c;
	Edge(int _v,int _c){
		v=_v;
		c=_c;
	}
};
int dis[N],look[N],total[N];
vector<Edge>vec[N];
void init(int n){
	for(int i=1;i<=n;i++){
		dis[i]=INF;
		total[i]=0;
		look[i]=0; 
	}
}
int Spfa(int n,int start){
	queue<int> q;
	init(n);
	dis[start]=0;
	look[start]=1;
	total[start]=1;
	q.push(start);//push之前标记为1 
	while(!q.empty()){
		int u=q.front(); 
		q.pop();
		look[u]=0;//pop之后标记为0 
		for(int i=0;i<vec[u].size();i++){
			int v=vec[u][i].v;
			if(dis[v]>dis[u]+vec[u][i].c){
				dis[v]=dis[u]+vec[u][i].c;
				if(!look[v]){//核心:先松弛操作,再push
					look[v]=1;
					total[v]++;
					q.push(v);
					if(n<=total[v]) return 0;//这时候大于n,是负环
				}
			} 
		}
	}
	return 1;
}

int main(){
	//freopen("1.txt","r",stdin);
	int t,n,m,w,a,b,c;
	cin>>t;
	cin.ignore();
	for(int i=1;i<=t;i++){
		cin>>n>>m>>w;
		for(int i=1;i<=n;i++) vec[i].clear();
		for(int i=1;i<=m;i++){
			cin>>a>>b>>c;
			//存入边 
			vec[a].push_back(Edge(b,c));
			vec[b].push_back(Edge(a,c));
		}
		for(int j=1;j<=w;j++){
			cin>>a>>b>>c;
			vec[a].push_back(Edge(b,-c));
		}
		printf("%s\n",(Spfa(n,1)?"NO":"YES"));
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值