POJ2387 Til the Cows Come Home

Til the Cows Come Home
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 39985 Accepted: 13595

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

题意:输入了N和T,输入的T组数据,三个数分别代表从 i 点到 j 点的距离。求出从第一点到N点的最短距离,

思路:比较裸的的Dijkstra,然后趁机模拟了一遍Dijkstra算法,

代码”:

#include<iostream>
#include<cstdio>
#include<cstring>
#define MAXN 2003
using namespace std;

int T,N;
int dis[MAXN][MAXN];  //储存距离的邻接矩阵
int cost[MAXN];   //存放距离
bool vis[MAXN];   //用于标记当前点是否遍历过

void Dijkstra(int start)
{
	for(int i=1;i<=N;i++)
		cost[i]=dis[start][i];
	memset(vis,0,sizeof(vis));
	vis[start]=true;cost[start]=0;
	for(int i=1;i<=N;i++)
	{
		int NM=0x7ffffff,k;  //设置NM为一个很大的值是为了松弛,
		for(int j=1;j<=N;j++)
		{
			if(!vis[j] && NM>cost[j])
			{
				NM=cost[j];    //找出从这个点到其他邻接点的最短距离,并记下这个距离
				k=j;
			}
		}
		vis[k]=true;  //标记这个点已经遍历过
		for(int j=1;j<=N;j++)
		{
			if(!vis[j] && cost[j]>(dis[k][j]+cost[k]) ) cost[j]=dis[k][j]+cost[k]; //这个每次更新了到目标点的距离  保证是最短距离
		}
	}
}

int main()
{
	memset(dis,10,sizeof(dis));
	scanf("%d%d",&T,&N);
	for(int i=1;i<=N;i++)
		dis[i][i]=0;
	for(int i=1;i<=T;i++)
	{
		int x,y,len;
		scanf("%d%d%d",&x,&y,&len);
		dis[x][y]=dis[y][x]=min(len,dis[x][y]);  //如果多次输入同一条边,取其最小值
	}
	Dijkstra(1);
	printf("%d\n",cost[N]);
	return 0;
}

Python网络爬虫与推荐算法新闻推荐平台:网络爬虫:通过Python实现新浪新闻的爬取,可爬取新闻页面上的标题、文本、图片、视频链接(保留排版) 推荐算法:权重衰减+标签推荐+区域推荐+热点推荐.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值