UVa-1252 Twenty Questions (位运算)

Time Limit: 3000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu

 Status

Description

Download as PDF

Consider a closed world and a set of features that are defined for all the objects in the world. Each feature can be answered with ``yes" or ``no". Using those features, we can identify any object from the rest of the objects in the world. In other words, each object can be represented as a fixed-length sequence of booleans. Any object is different from other objects by at least one feature. 

You would like to identify an object from others. For this purpose, you can ask a series of questions to someone who knows what the object is. Every question you can ask is about one of the features. He/she immediately answers each question with ``yes" or ``no" correctly. You can choose the next question after you get the answer to the previous question. 

You kindly pay the answerer 100 yen as a tip for each question. Because you don't have surplus money, it is necessary to minimize the number of questions in the worst case. You don't know what is the correct answer, but fortunately know all the objects in the world. Therefore, you can plan an optimal strategy before you start questioning. 

The problem you have to solve is: given a set of boolean-encoded objects, minimize the maximum number of questions by which every object in the set is identifiable. 

Input 

The input is a sequence of multiple datasets. Each dataset begins with a line which consists of two integers, m and n: the number of features, and the number of objects, respectively. You can assume 0 < m$ \le$11 and 0 < n$ \le$128. It is followed by n lines, each of which corresponds to an object. Each line includes a binary string of length m which represent the value (``yes" or ``no") of features. There are no two identical objects. 

The end of the input is indicated by a line containing two zeros. There are at most 100 datasets. 

Output 

For each dataset, minimize the maximum number of questions by which every object is identifiable and output the result. 

Sample Input 

8 1 
11010101 
11 4 
00111001100 
01001101011 
01010000011 
01100110001 
11 16 
01000101111 
01011000000 
01011111001 
01101101001 
01110010111 
01110100111 
10000001010 
10010001000 
10010110100 
10100010100 
10101010110 
10110100010 
11001010011 
11011001001 
11111000111 
11111011101 
11 12 
10000000000 
01000000000 
00100000000 
00010000000 
00001000000 
00000100000 
00000010000 
00000001000 
00000000100 
00000000010 
00000000001 
00000000000 
9 32 
001000000 
000100000 
000010000 
000001000 
000000100 
000000010 
000000001 
000000000 
011000000 
010100000 
010010000 
010001000 
010000100 
010000010 
010000001 
010000000 
101000000 
100100000 
100010000 
100001000 
100000100 
100000010 
100000001 
100000000 
111000000 
110100000 
110010000 
110001000 
110000100 
110000010 
110000001 
110000000 
0 0

Sample Output 

0 
2 
4 
11 
9

题意:

有n个物体,m个特征,每个物体用一个m位01串表示,表示每个特征是具备还是不具备。我在心里想一个物体(一定在n个之中),由你来猜。

你每次能询问一个特征,我告诉你时候具备此特征,当你确定答案之后,将答案告诉我(告知答案不算一次询问)。如果你采用最优策略,最少需要询问几次能保证猜到?

分析:

还是紫书上面位运算的黑科技,设一个集合s表示已经询问的特征集,在这个集合中有些是你心里想的物体w具备的,剩下的是w不具备的。用集合表示已确认物体w具备的特征集,则a一定是s的子集。

设d(s,a)表示已经问了特征集s,其中已确认w所具备的特征集为a时,还需要询问的最小次数。如果下一次提问的对象是特征k,则询问次数为:

max{d(s+{k},a+{k}),d(s+{k},a)}+1

即是在已知w特征k的情况下,选出需要询问的最小次数中的最大值。用来保证询问该次数一定能猜到。

能够把集合位运算处理好,其实还是简单的dp。

<span style="font-size:12px;">#include <algorithm>
#include <iostream>
#include <sstream>
#include <cstring>
#include <cstdlib>
#include <string>
#include <vector>
#include <cstdio>
#include <cmath>
#include <queue>
#include <stack>
#include <map>
#include <set>
using namespace std;
#define INF 0x3f3f3f3f
const int N=200005;
const int mod=1e9+7;

int n,m,kase;
int q[128][128],cnt[1<<11][1<<11],vis[1<<11][1<<11],d[1<<11][1<<11];

int dp(int s,int a) {
    if (cnt[s][a]<=1) {
        return 0;
    }
    if (cnt[s][a]==2) {
        return 1;
    }
    int& ans=d[s][a];
    if (vis[s][a]==kase) {
        return ans;
    }
    vis[s][a]=kase;
    
    ans=m;
    for (int k=0; k<m; k++) {
        if (!(s&(1<<k))) {
            int s2=s|(1<<k),a2=a|(1<<k);
            if (cnt[s2][a2]>=1&&cnt[s2][a]>=1) {
                int need=max(dp(s2,a2),dp(s2, a))+1;
                ans=min(ans, need);
            }
        }
    }
    return ans;
}

void init(){
    for (int s=0; s<(1<<m); s++) {
        for (int a=s; a; a=(a-1)&s)
            cnt[s][a]=0;
        cnt[s][0]=0;
    }
    for (int i=0; i<n; i++) {
        int features=0;
        for (int f=0; f<m; f++) {
            if (q[i][f]==1) {
                features|=(1<<f);
            }
        }
        for (int s=0; s<(1<<m); s++) {
            cnt[s][s&features]++;
        }
    }
}

int main() {
    memset(vis, 0, sizeof(vis));
    kase=0;
    while (cin>>m>>n&&n) {
        ++kase;
        string temp;
        for (int i=0; i<n; i++) {
            cin>>temp;
            for (int j=0; j<m; j++) {
                q[i][j]=temp[j]-'0';
            }
        }
        init();
        cout<<dp(0, 0)<<endl;
    }
    return 0;
}</span>

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值