2053 Switch Game

77 篇文章 0 订阅
40 篇文章 0 订阅


Switch Game

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13176    Accepted Submission(s): 8013


Problem Description
There are many lamps in a line. All of them are off at first. A series of operations are carried out on these lamps. On the i-th operation, the lamps whose numbers are the multiple of i change the condition ( on to off and off to on ).
 

Input
Each test case contains only a number n ( 0< n<= 10^5) in a line.
 

Output
Output the condition of the n-th lamp after infinity operations ( 0 - off, 1 - on ).
 

Sample Input
  
  
1 5
 

Sample Output
  
  
1 0
Hint
hint
Consider the second test case: The initial condition : 0 0 0 0 0 … After the first operation : 1 1 1 1 1 … After the second operation : 1 0 1 0 1 … After the third operation : 1 0 0 0 1 … After the fourth operation : 1 0 0 1 1 … After the fifth operation : 1 0 0 1 0 … The later operations cannot change the condition of the fifth lamp any more. So the answer is 0.

有n盏灯,进行n次操作,在n次操作后判断最后一盏灯是开还是关。

这个题打破了我的数学底线...我真的没有学好数学...甚至高中的数学


方法一:

这也是我最先想出的方法。直接建立一个数组,模拟灯的开关。

上代码:

<span style="font-size:14px;">#include <stdio.h>
#include <string.h>
int main()
{
	int n;
	int i,j,index;
	int a[100005];
	while(~scanf("%d",&n))
	{
		memset(a,0,sizeof(a));
		index=0;
		for(i=1;i<=n;i++)
		{
			for(j=i;j<=n;j+=i)
				a[j]=(a[j]+1)%2;
		}
		
		printf("%d\n",a[n]);
		
	}
	
	return 0;
}</span>
方法二:

这是参考的别人的。

比如n=16,则在第1、2、4、8、16次操作的时候,第16号灯都会被调整,因为16是1、2、4、8、16的倍数。
共有5次,因为开始是关闭的,所以最后将是亮着的。
你可能已经发现,其实求第n盏灯最后的状态,只是求它的因子个数的奇偶性(因为对同一盏等调整两次就恢复原状态)。

#include <stdio.h>

int main(void)
{
    int i, c, n;
    while (scanf("%d", &n) != EOF)
    {        
        for (i = 1, c= 0; i <= n; i++)
        {
            if (n % i == 0)
                c++;
        }
        printf("%d\n", c & 1);
    }

    return 0;
}


方法三:

继续往下想。

因子是不会只有1个的,比如16 = 1 * 16 = 2 * 8 = 4 * 4
所以,因为A = a × b,如果所有的因子a都不等于b,则因子的个数一定是偶数。
唯一使A的因子的个数为奇数的可能是存在A = a × b 且 a = b。即A是完全平方数。就像刚刚的16 = 4 × 4。
所以只要判断输入的数是否为完全平方数即可。

#include <math.h>
#include <stdio.h>
#define S(x) (((int)x)*((int)x))
int main(void)
{
    int n;
    while (scanf("%d", &n) != EOF)
        printf("%d\n", S(sqrt(n)) == n);

    return 0;
}
效率当然很不一样了。


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值