poj 2240 Arbitrage(Floyd最短路)

27 篇文章 0 订阅
14 篇文章 0 订阅

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.
Input
The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line telling whether arbitrage is possible or not in the format “Case case: Yes” respectively “Case case: No”.
Sample Input
3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0
Sample Output
Case 1: Yes
Case 2: No

题意:给出各种货币兑换的汇率,问能否通过货币的兑换,获得盈利。
分析:
因为在做最短路专题,一上来就往最短路上去想了,首先题意理解错了,以为是第一种货币获得盈利,被示例误导了。当时想只需要求 i 货币到 j 货币兑换汇率最低,然后乘上 j 货币兑换 i 货币的汇率,实现盈利就可以了。这就有些贪心策略的意味了,但这种想法是错的。
正确解法其实很简单,只需要用Folyd的插点法的思想,求得汇率的最大值即可,最后判断,ans[ i ] i 的值大于1.0即获得盈利。该题目还有一个问题是,输入的都是字符串,我用map处理了一下,把string映射到了数字,方便处理。

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <math.h>
#include <map>
#define INF 1<<30
using namespace std;
map <string,int> match;
double ans[35][35];
int n,m;
void init()
{
    int i,j;
    if(!match.empty())
        match.clear();
    for(i=1;i<=n;i++)
    {
        for(j=1;j<=n;j++)
            ans[i][j]=0;
    }
    memset(ans,0,sizeof(ans));
}

void floyd()
{
    int i,j,k;
    for(k=1;k<=n;k++)
    {
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                if(ans[i][j] < ans[i][k]*ans[k][j])
                    ans[i][j] = ans[i][k]*ans[k][j];
            }
        }
    }

}

int main()
{
    int i,j;
    int cnt=0;
    char str1[1005],str2[1005];
    double rates;
    while(scanf("%d",&n),n)
    {
        cnt++;
        init();

        for(i=1;i<=n;i++)
        {
            scanf("%s",str1);
            match[str1]=i;
        }
        scanf("%d",&m);
        for(i=1;i<=m;i++)
        {
            scanf("%s %lf %s",str1,&rates,str2);
            ans[match[str1]][match[str2]]=rates;
        }
        floyd();        
        printf("Case %d: ",cnt);
        int peace=0;
        for(i=1;i<=n;i++)
        {
            if(ans[i][i]>1.0)
            {
                peace=1;
                break;
            }
        }
        if(peace)
            printf("Yes\n");
        else
            printf("No\n");
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值