ACDREAM 03C Robbers(贪心专场)

ACDREAM 03C Robbers

Problem Description

  N robbers have robbed the bank. As the result of their crime they chanced to get M golden coins. Before the robbery the band has made an agreement that after the robbery i-th gangster would get Xi/Y of all money gained. However, it turned out that M may be not divisible by Y.

The problem which now should be solved by robbers is what to do with the coins. They would like to share them fairly. Let us suppose that i-th robber would get Ki coins. In this case unfairness of this fact is |Xi/Y - Ki/M|. The total unfairness is the sum of all particular unfairnesses. Your task as the leader of the gang is to spread money among robbers in such a way that the total unfairness is minimized.
Input
The first line of the input file contains numbers N, M and Y (1 ≤ N ≤ 1000, 1 ≤ M, Y ≤ 10000). N integer numbers follow - Xi (1 ≤ Xi ≤ 10000, sum of all Xi is Y).
Output
Output N integer numbers - Ki (sum of all Ki must be M), so that the total unfairness is minimal.
Sample Input

3 10 4
1 1 2

Sample Output

2 3 5

题目大意:每组数据包含两个部分,第一行N, M, Y,第二行是N个整数X1 ~ XN。题目给出了一个公式: |Xi/YKi/M| , 要求求出使这个式子的值的和最小的N个k的值(k的和要为M)。
解题思路:将 |Xi/YKi/M| 转换成 s[i]=(MXi)/Y , 最后将s[i]相加得出sum,比较sum与M的大小,作出相应操作(具体见代码)。
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#define N 1005
using namespace std;
typedef long long ll;
int K[N];
double S[N];
struct rec{
    int id;
    double num;
}r[N];
int cmp1(rec a, rec b) {
    return a.num < b.num;
}
int cmp2(rec a, rec b) {
    return a.num > b.num;
};
int main() {
    int n;
    while (scanf("%d", &n) != EOF) {
        int M, Y;
        scanf("%d %d", &M, &Y);
        int X, sum = 0;
        for (int i = 0; i < n; i++) {
            scanf("%d", &X);
            S[i] = (M * X) / Y;
            K[i] = (int)S[i];
            if (1 - (S[i] - K[i]) < S[i] - K[i]) {
                K[i]++;         
            }
            r[i].num = abs((S[i] + 1.0) / M - X * 1.0 / Y) - abs(S[i] * 1.0 / M - X * 1.0 / Y);
            r[i].id = i; 
            sum += K[i];
        }
        if (sum < M) {
            int temp = M - sum;
            sort(r, r + n, cmp1);
            for (int i = 0; i < temp; i++) {
                K[r[i].id]++;
            }
        } else if (sum > M) {
            int temp = sum - M;
            sort(r, r + n, cmp2);
            for (int i = 0; i < temp; i++) {
                K[r[i].id]--;
            }
        }
        printf("%d", K[0]);
        for (int i = 1; i < n; i++) {
            printf(" %d", K[i]);
        }
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值